Opened 10 years ago

Closed 9 months ago

#4725 closed bug (invalid)

BeIDE causes a trip to KDL

Reported by: ilzu Owned by: mmlr
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/alpha1
Keywords: vfs vnode Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Opening Clip Up 2 (http://dev.osdrawer.net/projects/clipup) BeIDE project file with BeIDE on Haiku sends Haiku to KDL. Tested on VirtualBox 3.06 running Haiku Alpha 1 on MacOS X and on real hardware. The project file works when running on BeOS R5 (under VirtualBox). Screenshot of the initial KDL and backtrace attached.

Steps to reproduce:

1)Mount BeOS R5 disk or unzip BeIDe from R5 devtools package

2)Check out Clip Up source code from subversion

3)double click trunk/ClipUP2_x86.proj file from the folder you downloaded the source code.

4)When Tracker asks you to find application that can open the file, choose BeIDE

5)Welcome to Kernel Debugging Land

Expected behavior: BeIDE opens the project file (and if you don't have set up some symlinks, it complains of missing files and folders)

Attachments (2)

BeIDE_kdl1.png (4.5 KB ) - added by ilzu 10 years ago.
Initial KDL message
BeIDE_kdl2.png (90.7 KB ) - added by ilzu 10 years ago.
Stack crawl

Download all attachments as: .zip

Change History (8)

by ilzu, 10 years ago

Attachment: BeIDE_kdl1.png added

Initial KDL message

by ilzu, 10 years ago

Attachment: BeIDE_kdl2.png added

Stack crawl

comment:1 by axeld, 10 years ago

Component: - GeneralSystem/Kernel
Owner: changed from nobody to axeld

I just tried to reproduce the problem, but I can't - BeIDE just starts up with the project file. Can you still reproduce this issue with a recent revision?

Have you used the same image on real hardware as well under emulation? If you still have that image, and it's still reproducible, is there any way you could make this available?

To correct the SVN URL: http://svn.osdrawer.net/clipup.

comment:2 by ilzu, 10 years ago

I cannot reproduce it anymore either. It happened on a new R1 Alpha 1 install, installed on a usb flash memory, and happened on both, in VirtualBox and on real hardware. I'll try to reporoduce it again when I get back home, I think I have a backup of that install there.

comment:3 by axeld, 10 years ago

Owner: changed from axeld to mmlr

IIRC Michael could still reproduce this on his laptop.

comment:4 by bonefish, 9 years ago

Keywords: vfs vnode added

comment:5 by waddlesplash, 3 years ago

Still an issue?

comment:6 by waddlesplash, 9 months ago

Resolution: invalid
Status: newclosed

No reply in 2 years, closing as invalid.

Note: See TracTickets for help on using tickets.