Opened 10 years ago

Closed 9 years ago

#4797 closed bug (duplicate)

intel_extreme driver stuck in 16-bit mode

Reported by: luroh Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Graphics/intel_extreme Version: R1/Development
Keywords: Cc:
Blocked By: #5214 Blocking:
Has a Patch: no Platform: All

Description

device Display controller (VGA compatible controller, VGA controller) [3|0|0]
  vendor 8086: Intel Corporation
  device 27a2: Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller

My laptop display is stuck in 16-bit mode until removing the intel_extreme driver, although the screen preflet indicates it's operating in 32-bit mode. Vesa mode works fine.

Attachments (1)

screenshot.png (70.6 KB ) - added by luroh 10 years ago.

Download all attachments as: .zip

Change History (6)

by luroh, 10 years ago

Attachment: screenshot.png added

comment:1 by jackburton, 10 years ago

How can you tell it's in 16 bit mode ?

comment:2 by luroh, 10 years ago

If you look closely, the "HAIKU" letters in the screenshot display color bands around the edges (which are not present when using vesa).

comment:3 by luroh, 10 years ago

Oh, sorry, looking at the screenshot, you cannot actually see any color bands. I guess I just took it for granted they would show up in a screenshot, but that's obviously not the case. I'll revert shortly with a photo instead. :)

comment:4 by luroh, 10 years ago

Ok, it turns out getting the color bands to appear on a photo is not the easiest thing, so I guess you have to take my word for it. Anyhow, since the screenshot doesn't display any color bands, it seems the buffer is 32-bit but actual rendering is 16-bit.

comment:5 by luroh, 9 years ago

Blocked By: 5214 added
Has a Patch: unset
Resolution: duplicate
Status: newclosed

Closing as duplicate of #5214 which has more info and better pictures.

Note: See TracTickets for help on using tickets.