Opened 10 years ago

Closed 10 years ago

#4836 closed bug (duplicate)

CPU spikes in media_addon_server

Reported by: tangobravo Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: #4835 Blocking:
Has a Patch: no Platform: All

Description

My laptop gives occasional (a bit random, but usually 2 or 3 per minute) 100% CPU spikes in threads within the media_addon_server, often the "Yeah baby, very shagadelic" but sometimes the "Intel HD Audio control" thread. Happens with both HDA driver, and OSS (with hda moved to desktop). The spike lasts for a couple of seconds, and as these are real-time priority threads, seem to freeze the entire system.

Attached an output from scheduling_recorder showing the event. Also a syslog and listdev.

Attachments (3)

syslog.txt (248.6 KB) - added by tangobravo 10 years ago.
syslog
devices.txt (3.5 KB) - added by tangobravo 10 years ago.
listdev
scheduling_rec.zip (196.6 KB) - added by tangobravo 10 years ago.
scheduling_recorder output

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by tangobravo

Attachment: syslog.txt added

syslog

Changed 10 years ago by tangobravo

Attachment: devices.txt added

listdev

Changed 10 years ago by tangobravo

Attachment: scheduling_rec.zip added

scheduling_recorder output

comment:1 Changed 10 years ago by tangobravo

Not sure if it's related - but it also seems to freeze hard after about 20 minutes uptime. One core of the CPU stays pegged at 100%. Apps continue to update (terminal cursor flashes, for example), but no mouse/keyboard input is accepted and I can't enter KDL.

Also lowering the priorities of the media server threads doesn't prevent the freezes but just seems to shift it to different threads. Could this point to an interupt problem? Doing and int in KDL shows IRQ 10 shared by oss, ata * 2, ehci, uhci * 5 and marvel_yukon. It also says handled 37599, unhandled 2663723.

Other stuff: USB doesn't work on this laptop. Sound works with OSS, not with the native hda driver, although it does show up in media prefs.

comment:2 Changed 10 years ago by tangobravo

Version: R1/alpha1R1/Development

Oh, and this is hrev33724 gcc2hybrid. The alpha seemed stable on here (though no sound from hda still).

comment:3 Changed 10 years ago by tangobravo

I think this is a dupe of #4835 - after some more testing the audio does not seem to be to blame, as removing OSS too still didn't help. However disabling DMA in safe mode does seem to stop the spikes (and gets rid of all the unhandled interupts reported by "int" in KDL). Going to roll back to hrev33625 to see if that really was the cause.

comment:4 Changed 10 years ago by anevilyak

Blocked By: 4835 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.