Opened 10 years ago

Closed 10 years ago

#4845 closed bug (duplicate)

Tracker Crash while archiving on desktop...

Reported by: Super Dave Osbourne Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/alpha1
Keywords: Cc:
Blocked By: #4130 Blocking:
Has a Patch: no Platform: x86

Description

Selected two files on the standard distro desktop, archived, then launched the expander with a double click on archive, viewed and verified the contents via the remote clipboard contents with a copy and paste, then unarchived the contents, verified the folders, and the files, and finally moved them to the trash. Proceeded to set this up to repeat 1400+ times, and usually around 5-10 times it causes crashes. However, I have seen this script run repeatedly 100-200 times before the Tracker pukes.

http://www.vimeo.com/upload/video

http://pastie.org/668438

Change History (5)

comment:1 by Super Dave Osbourne, 10 years ago

Here is the dump of gdb right after the crash and 'debug' click on the given panel.

GNU gdb 6.3 Copyright 2004 Free Software Foundation, Inc. GDB is free software, covered by the GNU General Public License, and you are welcome to change it and/or distribute copies of it under certain conditions. Type "show copying" to see the conditions. There is absolutely no warranty for GDB. Type "show warranty" for details. This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

[tcsetpgrp failed in terminal_inferior: Invalid Argument] Thread 39365 caused an exception: Segment violation Reading symbols from /boot/system/runtime_loader...done. Loaded symbols for /boot/system/runtime_loader Reading symbols from /boot/system/lib/libbe.so...done. Loaded symbols for /boot/system/lib/libbe.so Reading symbols from /boot/system/lib/libtracker.so...done. Loaded symbols for /boot/system/lib/libtracker.so Reading symbols from /boot/system/lib/libroot.so...done. Loaded symbols for /boot/system/lib/libroot.so Reading symbols from /boot/system/lib/libstdc++.hrev4.so...done. Loaded symbols for /boot/system/lib/libstdc++.hrev4.so Reading symbols from /boot/system/lib/libtranslation.so...done. Loaded symbols for /boot/system/lib/libtranslation.so Reading symbols from /boot/system/lib/libtextencoding.so...done. Loaded symbols for /boot/system/lib/libtextencoding.so Reading symbols from /boot/system/add-ons/Translators/BMPTranslator...done. Loaded symbols for /boot/system/add-ons/Translators/BMPTranslator Reading symbols from /boot/system/add-ons/Translators/EXRTranslator...done. Loaded symbols for /boot/system/add-ons/Translators/EXRTranslator Reading symbols from /boot/system/lib/libilmimf.so...done. Loaded symbols for /boot/system/lib/libilmimf.so Reading symbols from /boot/system/lib/libz.so...done. Loaded symbols for /boot/system/lib/libz.so Reading symbols from /boot/system/add-ons/Translators/GIFTranslator...done. Loaded symbols for /boot/system/add-ons/Translators/GIFTranslator Reading symbols from /boot/system/add-ons/Translators/JPEG2000Translator...done. Loaded symbols for /boot/system/add-ons/Translators/JPEG2000Translator Reading symbols from /boot/system/add-ons/Translators/JPEGTranslator...done. Loaded symbols for /boot/system/add-ons/Translators/JPEGTranslator Reading symbols from /boot/system/add-ons/Translators/PCXTranslator...done. Loaded symbols for /boot/system/add-ons/Translators/PCXTranslator Reading symbols from /boot/system/add-ons/Translators/PNGTranslator...done. Loaded symbols for /boot/system/add-ons/Translators/PNGTranslator Reading symbols from /boot/system/add-ons/Translators/PPMTranslator...done. Loaded symbols for /boot/system/add-ons/Translators/PPMTranslator Reading symbols from /boot/system/add-ons/Translators/RAWTranslator...done. Loaded symbols for /boot/system/add-ons/Translators/RAWTranslator Reading symbols from /boot/system/add-ons/Translators/RTF-Translator...done. Loaded symbols for /boot/system/add-ons/Translators/RTF-Translator Reading symbols from /boot/system/add-ons/Translators/SGITranslator...done. Loaded symbols for /boot/system/add-ons/Translators/SGITranslator Reading symbols from /boot/system/add-ons/Translators/STXTTranslator...done. Loaded symbols for /boot/system/add-ons/Translators/STXTTranslator Reading symbols from /boot/system/add-ons/Translators/TGATranslator...done. Loaded symbols for /boot/system/add-ons/Translators/TGATranslator Reading symbols from /boot/system/add-ons/Translators/TIFFTranslator...done. Loaded symbols for /boot/system/add-ons/Translators/TIFFTranslator Reading symbols from /boot/system/add-ons/Translators/WonderBrushTranslator...done. Loaded symbols for /boot/system/add-ons/Translators/WonderBrushTranslator [tcsetpgrp failed in terminal_inferior: Invalid Argument] [Switching to team /boot/system/Tracker (39355) thread w>Desktop (39365)] 0x0058fbc9 in BPrivate::Model::StatChanged ()

from /boot/system/lib/libtracker.so

(gdb) bt #0 0x0058fbc9 in BPrivate::Model::StatChanged ()

from /boot/system/lib/libtracker.so

#1 0x005b8070 in BPrivate::BPoseView::AttributeChanged ()

from /boot/system/lib/libtracker.so

#2 0x005b6ebd in BPrivate::BPoseView::FSNotification ()

from /boot/system/lib/libtracker.so

#3 0x00537f45 in BPrivate::DesktopPoseView::FSNotification ()

from /boot/system/lib/libtracker.so

#4 0x005acb6c in BPrivate::BPoseView::MessageReceived ()

from /boot/system/lib/libtracker.so

#5 0x002bfdf7 in BLooper::DispatchMessage () from /boot/system/lib/libbe.so #6 0x0037ff49 in BWindow::DispatchMessage () from /boot/system/lib/libbe.so #7 0x00383d9c in BWindow::task_looper () from /boot/system/lib/libbe.so #8 0x002c1353 in BLooper::_task0_ () from /boot/system/lib/libbe.so #9 0x006970c8 in thread_entry () from /boot/system/lib/libroot.so #10 0x70184fec in ?? () (gdb)

comment:2 by Super Dave Osbourne, 10 years ago

and here is the link to the video, the original video link was not correct...

http://www.vimeo.com/7240612

comment:3 by aldeck, 10 years ago

A bug with similar symptoms was fixed recently, which revision are you testing with?

comment:4 by Super Dave Osbourne, 10 years ago

Haiku Alpha RC1, I will be going to nightly builds here for testing sooner or later.

comment:5 by aldeck, 10 years ago

Blocked By: 4130 added
Resolution: duplicate
Status: newclosed

Ok, then chances are very high that this is a duplicate of #4130. Just reopen if you see it again on revisions > hrev33769. Thanks for testing. Btw i'm curious what is that scripting tool you are using?

Note: See TracTickets for help on using tickets.