Opened 10 years ago

Closed 9 years ago

#4924 closed enhancement (invalid)

Nightly source tarballs

Reported by: matthiasr Owned by: haiku-web
Priority: normal Milestone: R1
Component: Website Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

SVN checkout is slow, and even more so on Haiku (not sure whether due to disk or network performance issues).

Providing a recent source tarball as a starting point for "svn update" would be very helpful.

Note that this had been fixed once (#20), but the link there no longer works and there is no indication of any alternative on the site.

Change History (3)

comment:1 by umccullough, 10 years ago

As far as I can tell, it would have to be more than just source in the tarball - it would also need to contain the hidden .svn directories which are somewhat configuration-dependent.

For example, newer svn clients create these directories in a way that is not compatible with older clients.

I guess someone would have to create an anonymous checkout on a Haiku box and zip it up.

Also, the tarballs referenced in #20 and provided on berlios were not svn update-able.

The URL is wrong there, it should have been ftp: ftp://download.berlios.de/pub/haiku/snapshots/

comment:2 by umccullough, 10 years ago

I should also mention that the hidden .svn directories contain another full duplicate of the code that was checked out, so a zip containing all the sources in a way that is svn update-able would be twice the size of just downloading the code using svn checkout (which does also compress the data as it's sent)

comment:3 by mmadia, 9 years ago

Resolution: invalid
Status: newclosed

Closing this as invalid, as no one has expressed interest in close to a full year.

Note: See TracTickets for help on using tickets.