Opened 9 years ago

Closed 4 months ago

#4950 closed bug (fixed)

KDL as soon as Deskbar and desktop appear

Reported by: Kev Owned by: nobody
Priority: high Milestone: R1
Component: File Systems/BFS Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I'm not sure if this is related, but something strange happened during my last successful boot on my Haiku partition. I sent an e-mail like normal, just a reply, no attachments. Then, every time the mail daemon would check for mail (every x minutes or when I used the context menu on the replicant) it would bring up the status bar sending an e-mail, and send it again. (Well, I haven't heard back yet, but I'm tentatively assuming it's the last one that it was sending repeatedly.)

Then, I noticed that even though I'd read all my messages, the replicant context menu always said that I had one new message. I opened the query, and tried a few times to mark the message as read, both by opening the e-mail and using the close->leave as read, and right clicking the item in the query results and choosing mark as read. Nothing made it go away, so I thought I'd reboot.

Now, every time I reboot, a split second after the Deskbar and desktop show up, I'm KDL'd. I can't remember the error message so I'll have to update later with that, but anyway, I'm on haiku-nightly-hrev33859-x86gcc2hybrid and hadn't had any problems, using it every day since the day that one was released.

Attachments (1)

syslog (447.0 KB) - added by Kev 9 years ago.

Download all attachments as: .zip

Change History (17)

Changed 9 years ago by Kev

Attachment: syslog added

comment:1 Changed 9 years ago by anevilyak

It's not completely outside the realm of possibility that you have filesystem corruption going on, but without the panic message and backtrace there really isn't much to go off here.

comment:2 Changed 9 years ago by Kev

http://img38.imageshack.us/img38/6358/kdli.png

comment:3 Changed 9 years ago by Kev

That common_read_link line is the one I was replying to (or maybe it's my reply, since, it was actually a forward and it doesn't say that on that line either. Anyway, same thread.)

comment:4 Changed 9 years ago by axeld

Component: System/KernelFile Systems/BFS
Version: R1/alpha1R1/Development

Please add images as attachments instead of putting it somewhere else.

comment:5 Changed 9 years ago by Kev

BTW, I forgot to mention I ran chkbfs on each of my partitions from BeOS and none of them reported errors.

Re: attachments, I couldn't seem to get the file small enough for the limits imposed while still being able to read the text in it. So that was the only way I could think of to do it. Besides...less burden on your servers, right?

If there's nothing else I can try, I'd like to upgrade to the latest nightly so there's a chance I can be using Haiku again...please advise...

comment:6 Changed 9 years ago by anevilyak

R5's chkbfs really doesn't check/fix all that much except block allocation mismatches, it can't/won't try to handle more complex problems...if you can boot a Haiku Live CD you could try running checkfs on the Haiku partitions from there though.

comment:7 Changed 9 years ago by Kev

Unfortunately, I don't have one. Is there anything I can do on bootup or from R5, or should I just upgrade?

comment:8 Changed 9 years ago by axeld

This seems to be just a bug in BFS (with long symlinks) - this won't go away by running checkfs, I'm afraid :-)

comment:9 Changed 6 years ago by scottmc

Do you still have this issue or can we assume that this has been fixed in the past 3 years?

comment:10 Changed 6 years ago by Kev

I haven't been using Haiku for e-mail since I had some data loss issues a few years ago. And also kind of left IT for a while. Since then I've written over my Haiku system with Alpha 4.1, so after doing that I'm not sure how to try to reproduce it. Maybe Axel can comment having had a better idea of what the bug actually was?

comment:11 Changed 6 years ago by axeld

I've pretty much forgotten about this one. Since I also have no recollection of having fixed it, let's just keep the ticket open for now.

comment:12 Changed 6 years ago by Kev

Unfortunately I can't test it now, since Gmail POP access is currently unsupported by Haiku. But if/when that works again I'll give it a shot.

comment:13 Changed 20 months ago by axeld

Do you still have that image by any chance? I'd like to look into it, but it's hard without actually seeing the KDL (that's why I asked for an attachment; not that I knew that it would take forever until I would look at it).

comment:14 Changed 20 months ago by axeld

It might actually be a duplicate of #5282, in which case it would have been fixed in the mean time.

comment:15 Changed 20 months ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:16 Changed 4 months ago by waddlesplash

Resolution: fixed
Status: assignedclosed

Presuming fixed, then. Please open a new ticket if it's still around.

Note: See TracTickets for help on using tickets.