Opened 10 years ago

Last modified 8 months ago

#4964 new bug

bootup hangs with dual screen

Reported by: farvardin Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers Version: R1/alpha1
Keywords: boot-failure, has-workaround Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I have a computer with a nvidia integrated video (GeForce 6100), and a pciexpress nvidia video card (GeForce 8600).

I'm aware the GeForce 8600 is not supported by the accelerated nvidia driver on Haiku, but it failbacks to the vesa driver without problem, when dual screen is not enabled in the bios. But when it's enabled, the computer hangs at the end of the bootup (last icon on the haiku logo). When requesting Haiku to boot with "fail-safe video mode", I can boot normally to the desktop.

When enabling log during bootup, I can see it hangs after saying:

"loaded driver .... vesa" (probably for the GeForce 8600), then "AGP:get_ntlh_agp_info (index 0) (I don't have agp card), "Register_domain (4, link), then nothing more, maybe it's probing for more hardware, but after 10 minutes it's the same.

At least it should start and run the desktop, even if only one screen is supported at the same time.

Attachments (1)

listdev_farvardin.txt (3.6 KB) - added by farvardin 10 years ago.
listdev for my hardware

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by farvardin

Attachment: listdev_farvardin.txt added

listdev for my hardware

comment:1 Changed 14 months ago by waddlesplash

Keywords: boot-failure has-workaround added; dual screen nvidia "dual screen" removed

comment:2 Changed 8 months ago by waddlesplash

Still an issue?

Note: See TracTickets for help on using tickets.