Opened 10 years ago

Closed 8 years ago

#4970 closed bug (fixed)

Debugger crashes with corrupt memory, seems reproducible

Reported by: stippi Owned by: bonefish
Priority: normal Milestone: R1
Component: Applications/Debugger Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

On hrev33966, I compiled Debugger and MediaPlayer from hrev34009. Then I run the resulting MediaPlayer executable like this:

generated/objects/haiku/x86/release/apps/debugger/Debugger generated/objects/haiku/x86/debug_1/apps/mediaplayer/MediaPlayer

In the Images tab, I close the tree view handle for MainApp.cpp and open the one for MainWin.cpp below it. Scrolling a bit, I find the entry for MainWin::OpenPlaylistEntry() and select it. I set a breakpoint at the beginning of the function. Then I press the Run button and drop an MP3 into MediaPlayer. On the second invokation of F10, the Debugger crashes reproducibly. Usually, it's the following stack crawl:

Thread 7288 caused an exception: Segment violation
...
[Switching to team generated/objects/haiku/x86/release/apps/debugger/Debugger gene (7283) thread worker (7288)]
0x0028856e in LoadImageDebugInfoJob::Do ()
(gdb) bt
#0  0x0028856e in LoadImageDebugInfoJob::Do ()
#1  0x0029001f in Worker::_ProcessJobs ()
#2  0x002903af in Worker::_WorkerLoop ()
#3  0x0029047c in Worker::_WorkerLoopEntry ()
#4  0x006729ed in thread_entry () from /boot/system/lib/libroot.so
#5  0x7003ffec in ?? ()

But the first time I got this crash, I was messing a bit in the variables view before stepping, and then it crashed in realloc().

Change History (5)

comment:1 Changed 10 years ago by stippi

Oops, this may be important: Before it crashes, it prints to the command line:

DwarfManager::File::Load("/boot/system/add-ons/media/plugins/aiff_reader"): no .debug_info or .debug_abbrev.

comment:2 Changed 8 years ago by anevilyak

Do you by any chance still have a reproducible testcase for this one? At least I haven't managed to replicate it with the steps outlined above.

comment:3 Changed 8 years ago by anevilyak

ping.

comment:4 Changed 8 years ago by stippi

Sorry, no time at all. If you can't reproduce anymore, feel free to mark fixed.

comment:5 Changed 8 years ago by anevilyak

Resolution: fixed
Status: newclosed

Thanks for the update, please reopen if you do happen to encounter it again.

Note: See TracTickets for help on using tickets.