Opened 10 years ago

Closed 10 years ago

#4972 closed bug (invalid)

BePdf and Beam crash app_server on start

Reported by: jackburton Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: gcc4 hybrid Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

This is on a gcc4 hybrid installation, hrev34059. Starting either BePDF or Beam result in an app_server crash. syslog follows.

Change History (4)

comment:1 Changed 10 years ago by jackburton

Oh wll the pictures are useless, but it's 100% reproducible.

comment:2 Changed 10 years ago by stippi

I've had this happen to me with Beam as well. Doing a clean installation (versus jam update-all) solved this for me. But then the revision I upgraded to had other problems, and so I downgraded to hrev33966 for the meantime. But in any case, please try backing up your settings and doing a clean install, can you start Beam again?

comment:3 Changed 10 years ago by axeld

It would still be interesting what is actually happening. A stack trace would be nice to have, at least.

comment:4 in reply to:  2 Changed 10 years ago by jackburton

Resolution: invalid
Status: newclosed

Replying to stippi:

I've had this happen to me with Beam as well. Doing a clean installation (versus jam update-all) solved this for me. But then the revision I upgraded to had other problems, and so I downgraded to hrev33966 for the meantime. But in any case, please try backing up your settings and doing a clean install, can you start Beam again?

You're right. I did a clean installation and now both works. To Axel: From memory the backtrace involved DeskTop::ShowWindow(), and Window::SetVisible(). Unfortunately I can't remember any more, and since the pictures I took were crap, let's close this as invalid.

Beam can't install the deskbar replicant since it can't resolve a symbol, but this should be another ticket, I guess.

Note: See TracTickets for help on using tickets.