Opened 9 years ago

Closed 9 years ago

#5019 closed bug (fixed)

Recieving of big files stops just after depletion of the memory for cache.

Reported by: siarzhuk Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/Stack Version: R1/alpha1
Keywords: Cc: fredrik.holmqvist@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

To reproduce this problem you need:
a) local network connection to HTTP or FTP server;
b) file at this server with size bigger or equal to amount of available on your PC physical memory;
c) enough free place on the local hard drive.

Steps to reproduce:
1) Open Activity Monitor application and activate "Network Receive" and "Cached Memory" traces.
2) Open terminal, go to partition with enough free space and start receiveing the file with wget or ftp client.
3) wait until the cached memory trace in the Activity Monitor increasing up.
4) some time after the moment the "cached memory" trace goes "horizontally", the trace "Network Receive" drops to 0 and can stick in this state for a very long time.
5) to restore receiving process you can open new Terminal window or perform some writing/reading activity on your hard drive. For example you can take a screenshot by pressing Print button on your keyboard. See attached screenshot for graphical representation of this problem.

Probably you will need repeat steps 1-5 again to reproduce the problem. Note that you have to remove just received file to reset cached memory.

That problem is reproducible on all my PC with rtl8139, rtl8169, sis191 NICs. It was also reproduces by another person on intel pro 100V NIC. I think it is a generic netwrok or file system issue.

Note: I have traced this issue in my sis191 driver and saw, that at the moment of the "traffic fall" all receive buffers going full and ready to be acquired by network stack. So this looks like a system issue, not driver issue.

Attachments (1)

screenshot1.png (43.9 KB) - added by siarzhuk 9 years ago.
Screen of activity monitor during full bandwidth receive test.

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by siarzhuk

Attachment: screenshot1.png added

Screen of activity monitor during full bandwidth receive test.

comment:1 Changed 9 years ago by tqh

Cc: fredrik.holmqvist@… added

comment:2 Changed 9 years ago by siarzhuk

Resolution: fixed
Status: newclosed

Fixed in hrev35425. Thank you, Ingo!

Note: See TracTickets for help on using tickets.