Opened 13 years ago

Closed 10 years ago

#507 closed bug (fixed)

[VLC] slider flickering

Reported by: diver Owned by: stippi
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by modeenf)

Open any file in vlc and that press stop. Now look at slider, it will flicker twice in a second.

Change History (10)

comment:1 Changed 13 years ago by diver

Also note that slider color is different in R5. (don't want to create sepatate bug for such small thing :-) )

comment:2 Changed 13 years ago by jackburton

Our BSlider doesn't use an offscreen bitmap to draw itself, might be the cause of this problem.

comment:3 Changed 13 years ago by stippi

No, he means the seeking slider, which was written from scratch (by me :-). VLC checks the playback status on pulse. I think twice in a second. I don't know what's causing the flickering but I can have a look.

comment:4 Changed 13 years ago by stippi

Status: newassigned

comment:5 Changed 13 years ago by axeld

Owner: changed from axeld to stippi

comment:6 Changed 13 years ago by axeld

Status: assignednew

comment:7 Changed 11 years ago by scottmc

Platform: All

Does this still happen for anyone? I tried to see it but maybe I'm not doing it right?

comment:8 Changed 11 years ago by diver

Component: - GeneralServers/app_server

BTW, MediaPlayer's seeking slider have the same issue.

comment:9 Changed 10 years ago by diver

Version: R1 development

I can't reproduce it in VirtualBox 3.0.4

comment:10 Changed 10 years ago by modeenf

Description: modified (diff)
Resolution: fixed
Status: newclosed

Can't reproduce it on real hardware ether, so I'll close it.

Note: See TracTickets for help on using tickets.