Opened 9 years ago

Closed 8 years ago

#5075 closed bug (invalid)

showimage saves empty png file after conversion from gif

Reported by: streak Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/ShowImage Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

showimage saves empty png file after conversion from gif and saves empty png file after resizing png file that was created in wonderbrush.

This occurs on most recent nightlies.

Example. download some gif file from web, open with show image and try to resize it to 320x240 and save as png. PNG file will be empty.

the same situation occurs with png files made by wonderbrush.

Change History (6)

comment:1 Changed 9 years ago by streak

Any progress since?

comment:2 Changed 9 years ago by leavengood

Status: newin-progress

Sorry for the delay, but I've tested and confirmed this. It will take more debugging to solve it, but I'll be working on it over the next few days.

comment:3 Changed 9 years ago by streak

I see some regression here, coz on hrev38360 after a resizing an "example1.png" PNG and saving it to other "example2.png", showimage saves empty/transparent PNG. Previous version didnt have this "feature" :)

comment:4 Changed 8 years ago by Ka

Problem seems to be solved by revision 39605. No Problems saving PNGs as gifs and vice versa. But there is also no resinzing function any more (or am I blind??).

comment:5 Changed 8 years ago by bga

If I am not mistaken, Axel removed support for resizing images (not 100% sure about that tough. Anyone?

comment:6 Changed 8 years ago by humdinger

Resolution: invalid
Status: in-progressclosed

Right. No more resizing until ShowImage grows some more complete editing capabilities. Another ingenious way of Axel to fix a bug: remove the bug together with the feature. :D

Note: See TracTickets for help on using tickets.