Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#51 closed bug (fixed)

KDL when mounting a BFS cd-rom

Reported by: korli Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I'd like to try to mount a BFS CDRom on Haiku. So I tried to mount a BeOS Max CD with a 'mount -t bfs /dev/disk/scsi/1/0/0/raw /test' (this works on R5). Result is KDL below :

SCSI_CD -- cd_set_capacity: device=0x802e7880, capacity=317440, block_size=2048 bfs: invalid super block! vm_soft_fault: va 0xccccccfc not covered by area in address space vm_page_fault: vm_soft_fault returned error -2147478783 on fault at 0xccccccfc, ip 0x8007d4ad, write 1, user 0, thread 0x46 PANIC: vm_page_fault: unhandled page fault in kernel space at 0xccccccfc, ip 0x8007d4ad

Welcome to Kernel Debugging Land... Running on CPU 0 kdebug> sc iframe 0x81afffac (end = 0x81b00000) iframe 0x81afffac (end = 0x81b00000) iframe 0x81affa4c (end = 0x81affaa0) stack trace for thread 0x46 "mount"

kernel stack: 0x81afe000 to 0x81b00000

user stack: 0x7efe7000 to 0x7ffe7000

frame caller <image>:function + offset 81aff864 (+ 48) 80073ae1 <kernel>:kernel_debugger_loop + 0x0109 81aff894 (+ 32) 80073ff6 <kernel>:kernel_debugger + 0x0092 81aff8b4 (+ 176) 80073f5a <kernel>:panic + 0x0036 81aff964 (+ 48) 8004af0a <kernel>:vm_page_fault + 0x009a 81aff994 (+ 176) 80078b1a <kernel>:i386_handle_trap + 0x01ba iframe at 0x81affa4c eax 0x1 ebx 0x80409c00 ecx 0x10 edx 0xccccccfc esi 0x81affb50 edi 0x0 ebp 0x81affab4 esp 0x81affa7c eip 0x8007d4ad eflags 0x246 vector: 0xe, error code: 0x2 81affab4 (+ 48) 8003c31d <kernel>:get_mountFl + 0x0039 81affae4 (+ 64) 80042ca9 <kernel>:fs_syncFl + 0x0015 81affb24 (+ 48) 800431cd <kernel>:_kern_sync + 0x001d 81affb54 (+ 32) 8008094c <kernel>:sync + 0x000c 81affb74 (+ 160) 801c9726 <bfs>:Mount6VolumePCcUl + 0x016e 81affc14 (+ 80) 801ca416 <bfs>:bfs_mountFlPCcUlT1PPvPx + 0x004e 81affc64 (+ 192) 80042686 <kernel>:fs_mountFPcPCcT1UlT1b + 0x06ea 81affd24 (+ 128) 800441d5 <kernel>:_user_mount + 0x022d 81affda4 (+ 352) 8002da2c <kernel>:syscall_dispatcher + 0x06d0 81afff04 (+ 160) 80078ba3 <kernel>:i386_handle_trap + 0x0243 iframe at 0x81afffac eax 0x39 ebx 0x279658 ecx 0x5 edx 0x7ffe6eb8 esi 0x7ffef55e edi 0x7ffef577 ebp 0x7ffe6ef0 esp 0x81afffdc eip 0x221c8f eflags 0x10207 vector: 0x63, error code: 0x0 7ffe6ef0 00201096 7ffe6f80 00200bd5 7ffe6fac 00100661 7ffe6fdc 7ffe6fec kdebug>

Change History (15)

comment:1 by axeld, 14 years ago

That bug appears because fs_mount() didn't initialize some fields of the fs_mount structure when calling the file system's mount function - if you used any other FS-wide functions from there (like sync in the bug report), it crashed. hrev14223 should fix this bug.

comment:2 by axeld, 14 years ago

Status: newclosed

comment:3 by axeld, 14 years ago

Resolution: fixed

comment:4 by korli, 14 years ago

tested ok

comment:5 by korli, 14 years ago

Status: closedreopened

comment:6 by korli, 14 years ago

Resolution: fixed

comment:7 by korli, 14 years ago

Status: reopenedclosed

comment:8 by korli, 14 years ago

sorry bugzilla is weird

comment:9 by korli, 14 years ago

Resolution: fixed

comment:10 by korli, 14 years ago

Status: closedreopened

comment:11 by korli, 14 years ago

Resolution: fixed

comment:12 by korli, 14 years ago

Reopen the bug as it happens again :

loaded module /boot/beos/system/add-ons/kernel/drivers/dev/disk/scsi/scsi_cd loaded module /boot/beos/system/add-ons/kernel/drivers/dev/disk/scsi/scsi_dsk SCSI_CD -- get_geometry: SCSI_CD -- update_capacity: SCSI_CD -- cd_set_capacity: device=0x802e8880, capacity=318486, block_size=2048 SCSI_CD -- get_geometry: 2048, 1, 318486, 1, 5, 1, 1, 0 SCSI_CD -- get_geometry: done SCSI_CD -- cd_ioctl: 7: No error bfs: invalid super block! SCSI -- is_sg_list_dma_safe: S/G-entry crosses DMA boundary @0x1520000 SCSI -- is_sg_list_dma_safe: S/G-entry crosses DMA boundary @0x1520000 sync: device 5 couldn't sync: Device/File/Resource busy PANIC: BFS!

Welcome to Kernel Debugging Land... Running on CPU 0 kdebug> sc iframe 0x81b1ffac (end = 0x81b20000) iframe 0x81b1ffac (end = 0x81b20000) stack trace for thread 0x46 "mount"

kernel stack: 0x81b1e000 to 0x81b20000

user stack: 0x7efe7000 to 0x7ffe7000

frame caller <image>:function + offset 81b1fa64 (+ 48) 80074dd1 <kernel>:kernel_debugger_loop + 0x0109 81b1fa94 (+ 32) 800752e6 <kernel>:kernel_debugger + 0x0092 81b1fab4 (+ 176) 8007524a <kernel>:panic + 0x0036 81b1fb64 (+ 176) 801c9c80 <bfs>:Mount6VolumePCcUl + 0x0168 81b1fc14 (+ 80) 801ca966 <bfs>:bfs_mountFlPCcUlT1PPvPx + 0x004e 81b1fc64 (+ 192) 80042bbb <kernel>:fs_mountFPcPCcT1UlT1b + 0x0707 81b1fd24 (+ 128) 80044715 <kernel>:_user_mount + 0x022d 81b1fda4 (+ 352) 8002deac <kernel>:syscall_dispatcher + 0x06f0 81b1ff04 (+ 160) 80079e43 <kernel>:i386_handle_trap + 0x0243 iframe at 0x81b1ffac

eax 0x3b ebx 0x279978 ecx 0x5 edx 0x7ffe6eb8 esi 0x7ffef55e edi 0x7ffef577 ebp 0x7ffe6ef0 esp 0x81b1ffdc eip 0x221dcf eflags 0x10207 vector: 0x63, error code: 0x0

7ffe6ef0 00201096 7ffe6f80 00200bd5 7ffe6fac 00100661 7ffe6fdc 7ffe6fec kdebug>

comment:13 by korli, 14 years ago

Resolution: fixed

comment:14 by korli, 14 years ago

Status: reopenedclosed

comment:15 by korli, 14 years ago

Must be fixed as I can't reproduce it as of now.

Note: See TracTickets for help on using tickets.