Opened 10 years ago

Closed 10 years ago

#5108 closed bug (invalid)

Moving scrollbars with "grab" dysfunctional

Reported by: killa.fr0gg Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/alpha1
Keywords: scroll, mouse, graphics, window Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Scrolling with a scroll wheel works well, however I have noticed issues across the system whilst scrolling by dragging the scrollbar. Specifically, when doing so visual feedback is choppy and unresponsive, particularly if the mouse cursor moves to an area of the screen that is not in vertical alignment with the scrollbar.

Change History (6)

comment:1 by anevilyak, 10 years ago

Component: - GeneralKits/Interface Kit
Owner: changed from nobody to axeld

comment:2 by humdinger, 10 years ago

This sounds like another VirtualBox issue as scrolling by grabbing the scroll knob works smoothly over here running on hardware.

The second part about when not in "vertical alignment with the scrollbar" sounds like the 'snap-back' feature of the BeZillaBrowser (it doesn't happen anywhere else, with e.g. Tracker windows, right?): when you move the mouse pointer away from the scroll-knob over a certain threshold while dragging, the scrollbar snaps back to its starting position.

comment:3 by killa.fr0gg, 10 years ago

You are correct, sir. I will keep my misguided attempts at bug-tracking largely internal from now on, though if I may say so, that "snap-back" feature is (much) more annoying than it is convenient.

comment:4 by anevilyak, 10 years ago

The problem is that it's not easily fixed, since BezillaBrowser is derived from Firefox2, which does not use native widgets, and as such its scroll bar behavior is defined entirely internally in the mozilla libwidget codebase rather than being controlled by the OS.

in reply to:  3 comment:5 by kirilla, 10 years ago

Don't feel down killa.fr0gg.

Good places to ask around about oddness/bugs/intended behavior:

  • the IRC channel #haiku on freenode (might be the quickest)
  • the general haiku mailing-list (gets your question/observation the most exposure)
  • forums (less exposure, might be slow, I don't know)

comment:6 by humdinger, 10 years ago

Resolution: invalid
Status: newclosed

Yeah, don't feel bad, killa.fr0gg.

And don't stop reporting "real" bugs. :)
As a rule of thumb, before filing a ticket ask yourself: "If this is such an obvious bug, why wasn't it reported already?". Either it was (use the search function) or it's something specific to your installation. Then it's a good move to try the places kirilla mentioned to see if others experience the same or there's someone who even knows how to fix it.

Note: See TracTickets for help on using tickets.