Opened 10 years ago

Closed 10 years ago

#5116 closed bug (invalid)

ASUS M51Tr - no ACPI support

Reported by: kliput Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/ACPI Version: R1/Development
Keywords: asus, m51tr, turion, amd Cc: fredrik.holmqvist@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Hello. There is no ACPI (and in consequence no CPU scaling) support for ASUS M51Tr notebook.

Main hardware in this notebook:

  • CPU: AMD Turion ZM80
  • Graphics: Integrated ATI Mobility Radeon HD3200 and ATI Mobility Radeon HD3470 (ATI Hybrid Graphics)
  • RAM: 3GB
  • Chipset: 780G (AMD Puma platform)

Tested on Haiku R1/Alpha and nightly GCC4h revision 34514.

There was bug in Linux kernel (versions 2.6.22 - 2.6.29.1) that hangs system on boot with ACPI enabled. This was caused by bug in MTRR support. If this will be helpful, here is thread about this bug: http://bugzilla.kernel.org/show_bug.cgi?id=11541

Attached: listdev, listusb, syslog, listimage | grep drivers/

Attachments (4)

listdev.txt (4.8 KB ) - added by kliput 10 years ago.
syslog.txt (77.3 KB ) - added by kliput 10 years ago.
listimage-grep-drivers.txt (1.3 KB ) - added by kliput 10 years ago.
listusb.txt (530 bytes ) - added by kliput 10 years ago.

Download all attachments as: .zip

Change History (6)

by kliput, 10 years ago

Attachment: listdev.txt added

by kliput, 10 years ago

Attachment: syslog.txt added

by kliput, 10 years ago

Attachment: listimage-grep-drivers.txt added

comment:1 by kliput, 10 years ago

Keywords: turion added; trurion removed

by kliput, 10 years ago

Attachment: listusb.txt added

comment:2 by tqh, 10 years ago

Cc: fredrik.holmqvist@… added
Resolution: invalid
Status: newclosed

ACPI is disabled by default. ACPI has had a lot of fixes since the alpha, so if you want to test it you should get a recent build and uncomment "#acpi true" in ~/config/settings/kernel/drivers/kernel

Reopen this bug if you think it's a problem after you tested the above.

Note: See TracTickets for help on using tickets.