Opened 9 years ago

Closed 9 years ago

#5159 closed bug (fixed)

"New Tab" Crashes Terminal

Reported by: bonefish Owned by: jackburton
Priority: high Milestone: R1
Component: Applications/Terminal Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by bonefish)

hrev34721, gcc4

Cmd-T or menu item "New Tab" reliably cause Terminal to crash:

Thread 920 caused an exception: Segment violation
[Switching to team /boot/system/apps/Terminal (913) thread w>Terminal 1 (920)]
0x0021b1a6 in InlineInput::IsActive ()
(gdb) bt
#0  0x0021b1a6 in InlineInput::IsActive ()
#1  0x00225e78 in TermView::Draw ()
#2  0x00392a60 in BView::_Draw () from /boot/system/lib/libbe.so
#3  0x0039d359 in BWindow::DispatchMessage () from /boot/system/lib/libbe.so
#4  0x00398ec5 in BWindow::task_looper () from /boot/system/lib/libbe.so
#5  0x002e8090 in BLooper::_task0_ () from /boot/system/lib/libbe.so
#6  0x00726bdb in thread_entry () from /boot/system/lib/libroot.so
#7  0x700c1fec in ?? ()

debug server:

KERN: vm_soft_fault: va 0x72656000 not covered by area in address space
KERN: vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x72656893, ip 0x21b1a6, write 0, user 1, thread 0x398
KERN: vm_page_fault: thread "w>Terminal 1" (920) in team "Terminal" (913) tried to read address 0x72656893, ip 0x21b1a6 ("Terminal_seg0ro" +0x1b1a6)
KERN: debug_server: Thread 920 entered the debugger: Segment violation
KERN: stack trace, current PC 0x21b1a6  _ZNK11InlineInput8IsActiveEv + 0x6:
KERN:   (0x700c1bac)  0x225e78  _ZN8TermView4DrawE5BRect + 0x30e
KERN:   (0x700c1c3c)  0x392a60  _ZN5BView5_DrawE5BRect + 0x7e
KERN:   (0x700c1c6c)  0x39d359  _ZN7BWindow15DispatchMessageEP8BMessageP8BHandler + 0x1799
KERN:   (0x700c1f3c)  0x398ec5  _ZN7BWindow11task_looperEv + 0x277
KERN:   (0x700c1f9c)  0x2e8090  _ZN7BLooper7_task0_EPv + 0x30
KERN:   (0x700c1fbc)  0x726bdb  thread_entry + 0x2d

Change History (3)

comment:1 Changed 9 years ago by jackburton

Status: newassigned

Obviously it's caused by my latest commit. Fixing...

comment:2 Changed 9 years ago by bonefish

Description: modified (diff)

comment:3 Changed 9 years ago by jackburton

Resolution: fixed
Status: assignedclosed

Fixed in hrev34722.

Note: See TracTickets for help on using tickets.