Opened 9 years ago

Last modified 7 months ago

#5167 new bug

Intel HD Audio Controller [8086:293E] chipset recognized, but no sound

Reported by: cssvb94 Owned by: korli
Priority: normal Milestone: R1/beta2
Component: Drivers/Audio/HDA Version: R1/Development
Keywords: Cc: starsseed@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

GCC4 build hrev34759. Audio device is recognized and working under Linux and Win7. When media settings are opened no input control widgets are shown. Screenshots attached. Linux lshw and lspci output attached. Haiku syslog also attached.

Attachments (5)

screenshot1.png (21.7 KB) - added by cssvb94 9 years ago.
screenshot2.png (17.9 KB) - added by cssvb94 9 years ago.
lshw.txt (22.9 KB) - added by cssvb94 9 years ago.
Linux lshw
lspci.txt (40.1 KB) - added by cssvb94 9 years ago.
Linux lspci
syslog (93.9 KB) - added by cssvb94 9 years ago.
Haiku syslog

Download all attachments as: .zip

Change History (15)

Changed 9 years ago by cssvb94

Attachment: screenshot1.png added

Changed 9 years ago by cssvb94

Attachment: screenshot2.png added

Changed 9 years ago by cssvb94

Attachment: lshw.txt added

Linux lshw

Changed 9 years ago by cssvb94

Attachment: lspci.txt added

Linux lspci

Changed 9 years ago by cssvb94

Attachment: syslog added

Haiku syslog

comment:1 Changed 9 years ago by mmadia

Version: R1/alpha1R1/Development

comment:2 Changed 9 years ago by korli

Could you please try with the following diff ?

Index: src/add-ons/kernel/drivers/audio/hda/hda_codec.cpp
===================================================================
--- src/add-ons/kernel/drivers/audio/hda/hda_codec.cpp  (revision 36496)
+++ src/add-ons/kernel/drivers/audio/hda/hda_codec.cpp  (working copy)
@@ -46,6 +46,7 @@
 #define ANALOGDEVICES_VENDORID         0x11d4
 #define CIRRUSLOGIC_VENDORID           0x1013
 #define CONEXANT_VENDORID                      0x14f1
+#define IDT_VENDORID                           0x111d
 #define REALTEK_VENDORID                       0x10ec
 #define SIGMATEL_VENDORID                      0x8384
 
@@ -1328,7 +1329,9 @@
        { HDA_ALL, HDA_ALL, HDA_ALL, HDA_ALL, HDA_QUIRK_IVREF, 0 },
        { 0x10de, 0xcb79, CIRRUSLOGIC_VENDORID, 0x4206, HDA_QUIRK_GPIO1 | HDA_QUIRK_GPIO3, 0 },         // MacBook Pro 5.5
        { 0x8384, 0x7680, SIGMATEL_VENDORID, 0x7680, HDA_QUIRK_GPIO0 | HDA_QUIRK_GPIO1, 0},     // Apple Intel Mac
        { 0x106b, 0x00a3, REALTEK_VENDORID, 0x0885, HDA_QUIRK_GPIO0, 0},        // MacBook
+       { HDA_ALL, HDA_ALL, IDT_VENDORID, 0x76b2, HDA_QUIRK_GPIO0, 0},
 };

comment:3 Changed 9 years ago by cssvb94

Thank you korli, but I'm still not able to boot into Haiku to test it. Ref: ticket #5703.

comment:4 Changed 9 years ago by cssvb94

I've tried it - it didn't work.

comment:5 Changed 9 years ago by cssvb94

Release hrev37351: Still doesn't work. Do you need some more info?

comment:6 Changed 8 years ago by starsseed

Cc: starsseed@… added

comment:7 Changed 8 years ago by cssvb94

Does anybody working on that ticket? I still can't get it to work.

comment:8 Changed 5 years ago by waddlesplash

Still an issue on the latest nightlies?

comment:9 Changed 4 years ago by cssvb94

Yes, same issue. No sound, no audio sliders in settings. No issues under other OSs (Linux (any flavor), FreeBSD, Windows) Log shows that kernel recognizes it, but that's it. Restarting media services doesn't do anything useful. I would help with testing, but since I reported it 5 years! ago, not so much a progress or attention. I really like Haiku and I want to use it at least to play some music.

comment:10 Changed 7 months ago by pulkomandy

Milestone: R1R1/beta2
Note: See TracTickets for help on using tickets.