Opened 4 years ago

Closed 4 years ago

#5177 closed bug (fixed)

Kernel Panic (ASSERT FAILED) when copying a large file onto USB disk-on-key

Reported by: hitech Owned by: mmlr
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/alpha1
Keywords: usb, fat, disk, copy Cc: ahitech@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Reproduced on two different USB sticks, therefore seems to be a real bug, and not just a temporary flaw.

Working on Haiku revision 33109 (R1/alpha1) in VMWare Player 6.5 under Windows XP. USB sticks are: Kingston 4GB, SanDisk Cruiser Micro 2GB, both are formatted in FAT.

The problem is as follows:

  1. Get the current Haiku code from the repository :)
  2. Zip it using Zip-o-Matic.
  3. You'll receive a file with size of approximately 236 MB.
  4. Stick in the USB disk-on-key and allow the Haiku to discover it.
  5. Mount it in read-write mode (since you want to copy the file on it).
  6. Start copying the file. I copied to the root folder of the disk.
  7. Earlier or later, a KDL screen jumps in. It happens at about 186 MB copied.

Smaller files are copied without any problem.

I tried to workaround the problem using

dd if=haiku.zip of=/usb_stick/haiku.zip ifb=8192 ofb=8192
  • but it took A LOT of time and resulted in the same error.

Syslog complains about SCSI driver (see attached syslog.png file).

Some additional info is attached also.

Attachments (1)

bug_data.zip (46.0 KB) - added by hitech 4 years ago.
Some screenshots of the KDL and text files with loaded drivers, attached devices etc.

Download all attachments as: .zip

Change History (2)

Changed 4 years ago by hitech

Some screenshots of the KDL and text files with loaded drivers, attached devices etc.

comment:1 Changed 4 years ago by bonefish

  • Component changed from Drivers/USB to System/Kernel
  • Resolution set to fixed
  • Status changed from new to closed

Possibly fixed in hrev34655. Please reopen, if you can reproduce it with a current revision.

BTW, unlike individual attachments zip files are rather inconvenient for the people reading the ticket.

Note: See TracTickets for help on using tickets.