Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5220 closed bug (fixed)

[Tracker] can't move/select icons

Reported by: diver Owned by: anevilyak
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I was trying to create syslog to open another ticket when I've noticed that I can't move it (they were located on desktop) and even can't select them sometimes.

I've zipped them up and now I can reproduce this problem on a fresh image.
Tested with hrev34963 in VirtualBox and real hw.

Attachments (1)

syslogs.zip (77.3 KB) - added by diver 9 years ago.

Download all attachments as: .zip

Change History (15)

Changed 9 years ago by diver

Attachment: syslogs.zip added

comment:1 Changed 9 years ago by diver

Unzip it to desktop and try to move icons around.

comment:2 Changed 9 years ago by mmadia

Version: R1/alpha1R1/Development

comment:3 Changed 9 years ago by diver

It looks like hrev35679 improved this situation. Now if you drag a file it will move to a new position a second later.

comment:4 Changed 9 years ago by anevilyak

Owner: changed from axeld to anevilyak
Status: newin-progress

Thanks, I wasn't aware there was a ticket open for that problem. Are you saying it's fixed now, or can you describe the behavior a bit better? For large text files there's likely to be a small amount of lag since Tracker will open up the file to read its data and copy it into the message (so text clippings can work), but it shouldn't be that bad.

comment:5 Changed 9 years ago by diver

The icons from this archive are movable now. The only thing that bothers me is a small lag that happens between releasing the mouse with icon sticked to it and actual movement of this file to that position. Err... Not sure I can understand this description myself now, sorry :-/

comment:6 Changed 9 years ago by anevilyak

Ah...now I understand. The delay is with respect to the actual file move after letting go of the mouse, not the "pick up and start dragging" part?

comment:7 Changed 9 years ago by anevilyak

In any case, I'm not able to replicate any lag with the attached syslogs zip in either situation, is this in vbox or bare metal?

comment:8 Changed 9 years ago by anevilyak

I should say, with the log files contained in the zip.

comment:9 Changed 9 years ago by diver

Yeah, there is a delay which only happens after letting go of the mouse. It is in a vbox.

comment:10 Changed 9 years ago by anevilyak

May just be a vbox slowness issue then, in any case that sounds unrelated to the "unable to drag" problem. Can we consider this particular ticket fixed?

comment:11 Changed 9 years ago by diver

Icons on the desktop doesn't have this lag. Feel free to close it as original problem is fixed.

comment:12 Changed 9 years ago by stippi

Resolution: fixed
Status: in-progressclosed

Thanks for the update!

comment:13 Changed 9 years ago by anevilyak

Hi diver,

I'm curious, is there still any drag and drop lag with hrev35731 or later?

comment:14 Changed 9 years ago by diver

Just updated to hrev35731 and it's instant now, no more lag. Thanks!

Note: See TracTickets for help on using tickets.