Opened 13 years ago

Closed 12 years ago

#523 closed bug (fixed)

[BMenuBar] text color selection

Reported by: diver Owned by: stippi
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by stippi)

Selected text in BMenuBar is different from R5. Screenshot will follow.

Attachments (1)

BMenuBar.png (26.1 KB) - added by diver 13 years ago.
BMenuBar

Download all attachments as: .zip

Change History (10)

comment:1 Changed 13 years ago by diver

op_sys: AllHaiku

comment:2 Changed 13 years ago by jackburton

It's a feature :) Seriously... I can't check the various text colors on beos: does this apply only for disabled selected menu items ?

comment:3 Changed 13 years ago by diver

(In reply to comment #2)

It's a feature :) Seriously... I can't check the various text colors on beos: does this apply only for disabled selected menu items ?

Yep, i think it is.

comment:4 Changed 13 years ago by jackburton

Owner: changed from axeld to stippi

comment:5 Changed 13 years ago by jackburton

Anyway, I'm not sure what looks better... reassigning to stippi because he knows better...

Changed 13 years ago by diver

Attachment: BMenuBar.png added

BMenuBar

comment:6 Changed 13 years ago by stippi

ok, I'll have a look...

comment:7 Changed 13 years ago by stippi

Status: newassigned

comment:8 Changed 12 years ago by leavengood

Platform: All

I have taken a look at this and I'm not sure it is a problem. It can be reproduced on a vanilla Haiku image by opening MediaPlayer and selecting one of the disabled menus. Instead of the selected text staying the same disabled gray color like on R5, it becomes the inverse (aka the normal menu color.) The question is whether this is still indicative of a disabled menu. I think so. Either way it is a simple fix.

Someone should just make a decision and close this ticket.

comment:9 Changed 12 years ago by stippi

Description: modified (diff)
Resolution: fixed
Status: assignedclosed

fixed but I am too lazy to research in which revision...

Note: See TracTickets for help on using tickets.