Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#5231 closed bug (fixed)

[PackageInstaller] "Install to:" drop down box lists volumes it shouldn't list

Reported by: diver Owned by: sil2100
Priority: normal Milestone: R1
Component: Applications/PackageInstaller Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description


Attachments (2)

PackageInstaller.png (100.7 KB) - added by diver 10 years ago.
partition_patch.diff (1.7 KB) - added by sil2100 9 years ago.
Patch for this ticket + removal of unnecessary debugging output

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by diver

Attachment: PackageInstaller.png added

comment:1 Changed 9 years ago by mmadia

Version: R1/alpha1R1/Development

comment:2 Changed 9 years ago by sil2100

Status: newin-progress

comment:3 Changed 9 years ago by sil2100

Attaching a patch fixing this issue. The PackageInstaller will now ignore non-persistent partitions. The installer now chooses a default installation directory in the BMenuField for user paths as well (this was missing for an unknown reason). Also, I removed some unnecessary debugging output during package reinstallation.

Changed 9 years ago by sil2100

Attachment: partition_patch.diff added

Patch for this ticket + removal of unnecessary debugging output

comment:4 Changed 9 years ago by stippi

Resolution: fixed
Status: in-progressclosed

Applied in hrev36596, thanks! Don't you have commit access yourself, btw?

comment:5 Changed 9 years ago by sil2100

Oh my, that was really fast! Thanks stippi!

No, I do not have commit access. So for now I will be relying on your help in committing the patches, as always ;-)

Note: See TracTickets for help on using tickets.