Opened 10 years ago

Closed 5 months ago

#5298 closed bug (fixed)

[app_server] crash in ServerWindow::_DispatchViewMessage

Reported by: diver Owned by: nobody
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Here you can download a slimmed down version of Qt which is able to run QtDesigner (included in this archive).
After you download it and unpack double click "designer" binary.
You should see "New Form" wizard - click "Create" (see QtDesigner_step1.png)
Right click newly created empty form and select "Change toolTip" (see QtDesigner_step2.png)
You should see new window with OK/Cancel buttons, click "OK" ( see QtDesigner_step3.png)
At this poing app_server should crash with this backtrace:

Tested with hrev35180 in VirtualBox 3.0.12.

Attachments (5)

QtDesigner_step1.png (127.1 KB ) - added by diver 10 years ago.
QtDesigner_step2.png (150.2 KB ) - added by diver 10 years ago.
QtDesigner_step3.png (129.7 KB ) - added by diver 10 years ago.
app_server.png (14.8 KB ) - added by diver 10 years ago.
app_server_crash.png (4.4 KB ) - added by diver 9 years ago.

Download all attachments as: .zip

Change History (11)

by diver, 10 years ago

Attachment: QtDesigner_step1.png added

by diver, 10 years ago

Attachment: QtDesigner_step2.png added

by diver, 10 years ago

Attachment: QtDesigner_step3.png added

by diver, 10 years ago

Attachment: app_server.png added

comment:1 by diver, 10 years ago

Still reproducible in hrev35799.

comment:2 by bonefish, 9 years ago

Version: R1/alpha1R1/Development

comment:3 by diver, 9 years ago

New location of QtDesigner is here mirror.

Last edited 9 years ago by diver (previous) (diff)

comment:4 by diver, 9 years ago

I got a very similar back trace when switching several times from 32bit to 16bit workspace in VirtualBox.

Last edited 9 years ago by diver (previous) (diff)

by diver, 9 years ago

Attachment: app_server_crash.png added

comment:5 by axeld, 3 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:6 by diver, 5 months ago

Resolution: fixed
Status: assignedclosed

Can't reproduce this with current Qt5 Desinger on x86_64. Assuming fixed.

Note: See TracTickets for help on using tickets.