Opened 10 years ago

Closed 5 years ago

#5424 closed bug (no change required)

[gdb] hang after Ctrl-C

Reported by: Adek336 Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Applications/Command Line Tools Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Start gdb in Terminal, press Ctrl-c, now gdb stops responding.

Change History (5)

comment:1 by diver, 9 years ago

Still here in hrev38742, also gdb will start to eat CPU after Ctrl-c.

comment:2 by Freeman, 6 years ago

Can I use sigint to detect the user input and exit the program?

in reply to:  2 comment:3 by siarzhuk, 6 years ago

Replying to Freeman:

Can I use sigint to detect the user input and exit the program?

I have just compared gdb behavior with my FreeBSD box - on pressing Ctrl-C it prints "Quit" in the input line and left gdb running. I suspect gdb/readline uses more sophisticated signals handling (posix signals?) and cannot be fixed by adding just another handler.

AFAIR the "tree" version of gdb/readline was ported much earlier than posix signals support was implemented in Haiku - so it can have some "forgotten" hacks and workarounds to let it work. I suggest to port actual version of gdb for Haiku separately (or check if it is alrteady available in HaikuPorter) and try to reproduce the problem. gdb is 3rd-party software and will be outsorced soon - there are no sense to bother with outdated "tree" version anyway.

comment:4 by pulkomandy, 5 years ago

Milestone: R1Unscheduled

Problem is still here in hrev48547. I tested arm-none-eabi-gdb-x86 (port of a current GDB, but without native apps debug support) and it doesn't have the problem, so porting a current version of gdb would indeed probably fix this.

Moving out of R1 milestone since we have Debugger as a viable replacement now.

comment:5 by waddlesplash, 5 years ago

Resolution: no change required
Status: newclosed

GDB was outsourced and updated to a (somewhat) newer version; if this issue persists please report it at HaikuPorts.

Note: See TracTickets for help on using tickets.