Opened 9 years ago

Closed 9 years ago

#5436 closed bug (fixed)

installing troubles on VirtualBox

Reported by: andrey86 Owned by: axeld
Priority: high Milestone: R1
Component: System/Boot Loader Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Hello, I have installed Haiku-r1alpha1 on VirtualBox and have found some problems in the installation process.

At the beginning of installation I have selected partition on the "Onto" tab (name: Haiku, size: 2GB) and then pressed "Write Boot Sector On Haiku" and "Begin" buttons. After installation the system reported "Installation completed. Boot sector has been written to 'Haiku'...", but after rebooting VirtualBox reported "Boot Sector Not Found". So, message from the system at the end of installation was wrong.

Change History (2)

comment:1 in reply to:  description Changed 9 years ago by mmlr

Replying to andrey86:

At the beginning of installation I have selected partition on the "Onto" tab (name: Haiku, size: 2GB) and then pressed "Write Boot Sector On Haiku" and "Begin" buttons. After installation the system reported "Installation completed. Boot sector has been written to 'Haiku'...", but after rebooting VirtualBox reported "Boot Sector Not Found". So, message from the system at the end of installation was wrong.

No it actually wasn't. Both messages just concern two different boot sectors. One is the master boot record (MBR) which apparently didn't contain any chainloader/bootmanager and is why VirtualBox complained, the other is the partition boot record (PBR) which was installed by the Installer to make the partition bootable.

Was this an empty disk image partitioned by DriveSetup? If so, this one's fixed since quite a bit as the intel partitioning module installs a chainloader when writing a clean MBR now. Otherwise it's a duplicate of #5397.

comment:2 Changed 9 years ago by mmadia

Resolution: fixed
Status: newclosed

closing the ticket as per mmlr's comments.

Note: See TracTickets for help on using tickets.