Opened 9 years ago

Closed 7 years ago

Last modified 7 years ago

#5471 closed bug (fixed)

[Locale] language list is lowercase for some locales

Reported by: diver Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Kits/Locale Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Setting preferred language to some languages (like Russian or Ukrainian) sets available list to lowercase. Instead first letter of each language name should be capitalized, like it's done for English (default) locale. Same thing could be seen in ReadOnlyBootPrompt.
BTW, there are no components for both of them in Trac.
Tested with hrev35595.

Attachments (1)

language_list_ubuntu.png (71.7 KB) - added by diver 8 years ago.
language list from ubuntu 11.04 installer

Download all attachments as: .zip

Change History (15)

comment:1 Changed 9 years ago by diver

Version: R1/alpha1R1/Development

comment:2 Changed 9 years ago by diver

Component: PreferencesKits/Locale Kit
Owner: changed from nobody to pulkomandy

Still here in hrev36318.

comment:3 Changed 9 years ago by pulkomandy

Status: newassigned

Are you sure this is needed ? In French, language names are lowercase, while in English they need to always be uppercase. So, we can enforce that in the applications, but not as part of the locale kit itself.

comment:4 Changed 9 years ago by diver

Not sure, but at least in Russian, language names need to be uppercase.

comment:5 Changed 9 years ago by pulkomandy

That would be a bug on ICU side then.

comment:6 Changed 9 years ago by diver

AFAIR ICU was updated some time ago, but this bug is still here in hrev38300.

comment:7 Changed 9 years ago by zooey

Diver: I suppose you're a native speaker, but according to

http://meta.wikimedia.org/wiki/Capitalization_of_Wiktionary_pages#Capitalization_of_language_names

Russian language names are spelled in lower case.

Maybe ICU is correct, after all?

comment:8 Changed 9 years ago by diver

This wikimedia article is wrong about Capitalization of language names and Capitalization of names of peoples in Russian language at least.

comment:9 in reply to:  8 Changed 9 years ago by zooey

Replying to diver:

This wikimedia article is wrong about Capitalization of language names and Capitalization of names of peoples in Russian language at least.

Some more research has given me this: the Pons translation dictionary (German -> Russian) gives 'англи́йский язы́к м' as Russian translation for 'English'. That seems to indicate lowercase, too.

So, please give some sources for your claim.

comment:10 Changed 9 years ago by pulkomandy

It could also be expecting sentance case in this list. In french the languages are also lowercase, but alone in the list they could be uppercase as well, because it's a list and not words in a sentance.

comment:11 in reply to:  10 Changed 9 years ago by diver

Replying to pulkomandy:

It could also be expecting sentance case in this list. In french the languages are also lowercase, but alone in the list they could be uppercase as well, because it's a list and not words in a sentance.

Ahh, that's right!

Changed 8 years ago by diver

Attachment: language_list_ubuntu.png added

language list from ubuntu 11.04 installer

comment:12 Changed 8 years ago by diver

language list from ubuntu 11.04 installer

comment:13 Changed 7 years ago by diver

Resolution: fixed
Status: assignedclosed

Can't reproduce this anymore, closing.

comment:14 Changed 7 years ago by diver

Well it's still lowercased in Formatting tab in Locale preflet, but not on ReadOnlyBootPrompt.

Note: See TracTickets for help on using tickets.