Opened 9 years ago

Closed 9 years ago

Last modified 5 years ago

#5488 closed bug (fixed)

[ACPI] Haiku failed to boot on Compaq Evo PC [with checksum warning.]

Reported by: siarzhuk Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/ACPI Version: R1/alpha1
Keywords: Cc: fredrik.holmqvist@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by mmadia)

a) This behavior was observed on hrev35624
b) Both "apm true" and "acpi true" settings were uncommented in the kernel settings.
c) This system is a desktop Compaq brand PC.

Steps to reproduce:
a) Boot Haiku with activated acpi and apm in the kernel settings.
b) Boot process stops at some time. The terminal connected to COM1 displays the following message at this moment.

ACPI Warning: Incorrect checksum in table [ Р] - D0, should be 1C (20100121/tbutils-354)

Notes:
Complete syslog is attached.
listdev output is attached.

Any suggestions and testing cases are welcome!

Attachments (4)

syslog (41.1 KB) - added by siarzhuk 9 years ago.
listdev.txt (1.3 KB) - added by siarzhuk 9 years ago.
syslog.compaq.boot-acpi-on.log (61.3 KB) - added by siarzhuk 9 years ago.
syslog.compaq.boot-acpi-off.log (49.6 KB) - added by siarzhuk 9 years ago.

Download all attachments as: .zip

Change History (14)

Changed 9 years ago by siarzhuk

Attachment: syslog added

Changed 9 years ago by siarzhuk

Attachment: listdev.txt added

comment:1 Changed 9 years ago by siarzhuk

Component: - GeneralDrivers/ACPI
Description: modified (diff)

comment:2 Changed 9 years ago by tqh

Dunno if you should have ACPI and APM enabled at the same time. I might be wrong but I thought ACPI pretty much replaces APM. Probably doesn't affect the result though.

comment:3 in reply to:  2 Changed 9 years ago by siarzhuk

Replying to tqh:

Dunno if you should have ACPI and APM enabled at the same time. I might be wrong but I thought ACPI pretty much replaces APM. Probably doesn't affect the result though.

I have tried hrev357906 with disabled "apm" and only activated "acpi" - the result is the same.

But look on the mentioned warning message from different Haiku sessions:

ACPI Warning: Incorrect checksum in table [ Р] - D0, should be BE (20100121/tbutils-354)

ACPI Warning: Incorrect checksum in table [ Р] - D0, should be 13 (20100121/tbutils-354)

Note, that the checksum is always D0 but awaited values are different for different Haiku sessions.

And again - system boot process is stopped after this message.

comment:4 Changed 9 years ago by tqh

Cc: fredrik.holmqvist@… added

Can you check if this also is fixed in hrev35726?

comment:5 in reply to:  4 Changed 9 years ago by siarzhuk

Summary: [ACPI] Haiku failed to boot on Compaq brand PC with checksum warning.[ACPI] Haiku failed to boot on Compaq Evo PC [with checksum warning.]

Replying to tqh:

Can you check if this also is fixed in hrev35726?

I have used hrev35740 to check. Mentioned checksum messages are disappeared but the boot was not successfull anyway. I have attached two syslogs: first one was acquired with "acpi true" in kernel settings, second one was acquired with the same Live-CD with ACPI disabled from the boot menu. The system was booted successfully in the second [ACPI off] case.

Changed 9 years ago by siarzhuk

Changed 9 years ago by siarzhuk

comment:6 Changed 9 years ago by bonefish

Not sure, if that is the cause of the problem, but the MTRR ranges look broken. Will look into that.

comment:7 Changed 9 years ago by bonefish

Fixed the MTRR issue in hrev35753.

comment:8 Changed 9 years ago by siarzhuk

Resolution: fixed
Status: newclosed

Checked on hrev35757. This PC boots now with active ACPI and shutdown correctly. Thank you! Would you like to inspect the syslog acquired during successfull boot?

comment:9 in reply to:  8 Changed 9 years ago by bonefish

Replying to siarzhuk:

Checked on hrev35757. This PC boots now with active ACPI and shutdown correctly. Thank you! Would you like to inspect the syslog acquired during successfull boot?

Not me at least; maybe the "ACPI guys", though. The MTRR issue I could simulate (given the ranges from your syslog), so I don't expect any surprises in this regard.

comment:10 Changed 5 years ago by mmadia

Description: modified (diff)
Note: See TracTickets for help on using tickets.