Opened 13 years ago

Closed 12 years ago

#550 closed bug (fixed)

Looks like BMenus dont tint their colors

Reported by: mikael.konradson@… Owned by: jackburton
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version:
Keywords: Cc: diver
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by jackburton)

  1. Change colors using the menu preflet. (Choose a very dark color).
  2. Restart tracker
  3. you will now see the 3d effect colors with their original colors, a much

better (the correct) way would be to use tint_color /Darken/Lighten here. (LeftTop -RightTop/LeftBottom) should be using tint_color(HighColor(), B_LIGHTEN_*_COLOR). And the opposite coordinates should use a Darer version.

P.S I dont have the source here, maybe its already tinted, but its a bug though D.S /Mikael Konradsson

Change History (8)

comment:1 by mikael.konradson@…, 13 years ago

Rev: 17244. Sorry forgot that.

comment:2 by diver, 13 years ago

Cc: diver added

comment:3 by axeld, 13 years ago

Owner: changed from axeld to jackburton

comment:4 by axeld, 13 years ago

Summary: Lookes like BMenus doesnt tint their colorsLooks like BMenus dont tint their colors

comment:5 by jackburton, 13 years ago

Problem is that colors returned by ui_color() are fixed at the moment. Once this is fixed/changed, this bug should go away automatically.

comment:6 by jackburton, 12 years ago

Description: modified (diff)
Platform: All
Status: newassigned

I had a look at this bug again, and looks like I was wrong. The problem is that the menu preflet uses set_menu_info() to set the menu colors, but that function only updates the menu_info struct, and not the color returned by ui_color(B_MENU_BACKGROUND_COLOR). And, since we use either ui_color(B_MENU_BACKGROUND_COLOR) or the background_color member of menu_info to get the menu background color, we should make sure that DesktopSettingsPrivate::SetMenuInfo() also updates the ui_color.

comment:7 by jackburton, 12 years ago

Component: - GeneralKits/Interface Kit

comment:8 by jackburton, 12 years ago

Resolution: fixed
Status: assignedclosed

Fixed in hrev23070.

Note: See TracTickets for help on using tickets.