Opened 10 years ago

Closed 10 years ago

#5556 closed bug (invalid)

Slow draw performance with Nvidia Geforce4 440 on AGP 8x

Reported by: ormandj Owned by: rudolfc
Priority: normal Milestone: R1
Component: Drivers/Graphics/nVidia Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Hi,

When scrolling in terminal and other applications, I get a fair amount of vertical tearing, and sluggish draws. I've verified the nvidia accelerant is being used:

~> listimage 64 |grep accelerant

299 /boot/system/add-ons/accelerants/nvidia.accelerant 0x8cb000 0x903000 0 0

~>

It draws (visibly) about the same rate as my VESA installations on other systems.

Attached is a syslog, if more information is needed, please let me know.

Attachments (1)

syslog (56.3 KB ) - added by ormandj 10 years ago.

Download all attachments as: .zip

Change History (2)

by ormandj, 10 years ago

Attachment: syslog added

comment:1 by rudolfc, 10 years ago

Resolution: invalid
Status: newclosed

Hi there,

The speed should indeed be about the same since Haiku's app_server doesn't use hardware acceleration anymore. From what I hear the available old BeOS acceleration commands are not sufficient for the current way the app_server draws (it uses some newer techniques for 'eye candy' or so).

Closing the bug since it's no bug, but 'intended behaviour'. You will notice the same effect on all other graphics drivers. (Though PCIe's bandwidth is large enough so you won't notice it on such a gfx card, as opposed to AGP cards).

Greetings!

Rudolf.

Note: See TracTickets for help on using tickets.