Opened 9 years ago

Closed 9 years ago

#5575 closed bug (invalid)

Display problems with qemu sometimes

Reported by: jackburton Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/Development
Keywords: Cc: planche2k@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Every now and then (very often, actually, I get a garbled display when booting haiku in qemu). Qemu 0.11.0

Attachments (1)

Schermata.png (110.8 KB) - added by jackburton 9 years ago.

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by jackburton

Attachment: Schermata.png added

comment:1 Changed 9 years ago by bonefish

Your host system is Linux I suppose? Is this a new problem?

I can easily reproduce a similar screen with OpenSuse 11.2 and qemu 0.11.0, when resizing the qemu window manually. Changing the resolution via the Screen preflet from the standard 1024x768 to 1280x1024 more often than not also does the trick. While the latter might suggest an issue with Haiku's mode switching, the former implies a qemu bug IMO.

I'm pretty sure that at least the qemu window resizing problem did already exist when I started using qemu under OpenSuse 11.2 four months ago.

comment:2 in reply to:  1 Changed 9 years ago by jackburton

Replying to bonefish:

Your host system is Linux I suppose? Is this a new problem?

Ubuntu 9.10. I'd say it's a new problem, yes. But since I haven't tried haiku on qemu in a while, I can't say how much time it has been a problem.

I can easily reproduce a similar screen with OpenSuse 11.2 and qemu 0.11.0, when resizing the qemu window manually. Changing the resolution via the Screen preflet from the standard 1024x768 to 1280x1024 more often than not also does the trick. While the latter might suggest an issue with Haiku's mode switching, the former implies a qemu bug IMO.

Yeah, I thought that too. I'd keep this open, though, at least until the bug is recognized within qemu, or I can find an already opened ticket there.

comment:3 Changed 9 years ago by andreasf

Cc: planche2k@… added

Is this still around with 0.12.x? SDL or VNC?

comment:4 Changed 9 years ago by jackburton

Resolution: invalid
Status: newclosed

I haven't seen it anymore since I'm using qemu 0.12.3

Note: See TracTickets for help on using tickets.