Opened 9 years ago

Closed 9 years ago

#5598 closed bug (fixed)

BTextView character width is often incorrect for multi-byte characters

Reported by: axeld Owned by: axeld
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I haven't yet figured out how to reproduce it, but in Mail with character size 14 I have it quite often that once I use multi-byte characters (like äöüß), the width computation is incorrect, and the cursor is at a wrong position.

Change History (5)

comment:1 Changed 9 years ago by jackburton

I think it could be reproduced by opening a text file which contains lots of multibyte characters, like those in the canna input addon. At least, I remember once I fixed a couple of problems there by using those as test case.

comment:2 Changed 9 years ago by jackburton

And, indeed, it's reproducible by opening /boot/system/data/Canna/default/fixer.canna for example.

comment:3 Changed 9 years ago by diver

#2334 could be related.

comment:4 Changed 9 years ago by koki

Cc: koki added

FWIW, I also see this sporadically when writing emails in Japanese. It does not happen all the time though, and I am not sure what triggers it.

comment:5 Changed 9 years ago by zooey

Resolution: fixed
Status: newclosed

I was unable to reproduce this in hrev38006 (with the file mentioned and my own tests).

Most probably this was fixed with hrev36304 - please reopen if you encounter the problem again.

Note: See TracTickets for help on using tickets.