Opened 9 years ago

Closed 4 years ago

#5630 closed bug (fixed)

GCC4: headers/cpp/fenv.h don't find bits/c++config.h

Reported by: michaelvoliveira Owned by: jprostko
Priority: normal Milestone: Unscheduled
Component: Applications/Command Line Tools Version: R1/Development
Keywords: gcc build headers Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I don't know if it is a bug...

but..

While I'm use gcc4

the fenv.h header don't find c++config.h header at

/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/include/c++/4.3.3/i586-pc-haiku/bits

if I put at

/boot/develop/abi/x86/gcc4/tools/gcc-4.3.3-haiku-090629/include/c++/4.3.3/bits

the fenv.h enconters it, but

I got several errors...

If it is invalid please ignore...

Change History (9)

comment:1 Changed 9 years ago by michaelvoliveira

using rev35919

comment:2 Changed 9 years ago by bonefish

Please provide the following information:

  • kind of build (gcc2hybrid, gcc4,...),
  • How to reproduce to problem.

Note that (if applicable) those should always be provided in any ticket. Cf. http://dev.haiku-os.org/wiki/ReportingBugs.

comment:3 Changed 9 years ago by michaelvoliveira

Ah! Of course,

It's a Haiku gcc4hybrid.. clean.. that I made in the past week

I was trying to build a sdl game that scottmc told me

Freedroid http://freedroid.sourceforge.net/

so I use the following commands:

setgcc gcc4 ./configure --prefix=/boot/common

And the error appear...

comment:4 Changed 9 years ago by bonefish

Owner: changed from nobody to jprostko
Status: newassigned

The problem is that "/boot/develop/headers/cpp" is also part of the header search paths in C mode, which is why the wrong <fenv.h> header is picked up in that case.

In case Joseph turns up again the ticket is his.

comment:5 Changed 9 years ago by michaelvoliveira

Hum.. thanks!!

So.. I dropped the fenv.h for a momment and the build session runs smoothly...

comment:6 Changed 9 years ago by bonefish

Removed the "cpp" directory from the C headers in hrev36354. The problem should be fixed as soon as the gcc optional packages have been rebuilt.

comment:7 Changed 8 years ago by michaelvoliveira

I think that this ticket could be closed

comment:8 Changed 4 years ago by michaelvoliveira

Ping.

Somebody please close this ticket

comment:9 Changed 4 years ago by korli

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.