Opened 9 years ago

Closed 9 years ago

#5655 closed bug (fixed)

E-mail preferences crash on creating an account

Reported by: vooshy Owned by: axeld
Priority: normal Milestone: Unscheduled
Component: System/libroot.so Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

hrev35962 Haiku Creating an account on Mail, won't work anymore. allows adding all information but then crashes when OK button is pressed.

Attachments (6)

gdb-debug223-email (2.9 KB) - added by vooshy 9 years ago.
debug and bt
screenshot1.png (362.1 KB) - added by vooshy 9 years ago.
screenshot of crash
280310-shot (417.0 KB) - added by vooshy 9 years ago.
hrev35981 - crash no gdb
terminal-output-email (981 bytes) - added by vooshy 9 years ago.
terminal output
gdb-debug2308-email-28th (2.8 KB) - added by vooshy 9 years ago.
gdb debug
resolv.conf (60 bytes) - added by vooshy 9 years ago.
resolv file

Download all attachments as: .zip

Change History (17)

Changed 9 years ago by vooshy

Attachment: gdb-debug223-email added

debug and bt

Changed 9 years ago by vooshy

Attachment: screenshot1.png added

screenshot of crash

comment:1 Changed 9 years ago by vooshy

worked around it by putting in different password, not sure if this is still a bug so can be closed. I'm sure if it occurs to someone else it can be re-opened.

comment:2 Changed 9 years ago by jonas.kirilla

Component: Applications/MailSystem/libroot.so
Keywords: mail account removed
Owner: changed from bga to axeld
Summary: Mail Crash on creating an accountE-mail preferences crash on creating an account

I've seen this a lot lately. The root cause is likely not in the E-mail preferences (Preferences/Mail).

comment:3 Changed 9 years ago by jackburton

The DNSQuery class of Mail reads into resolv.conf. Maybe it simply doesn't like something which the new DHCPClient code writes in there (hrev35954 and later, but I'm sure there is an earlier commit)

comment:4 Changed 9 years ago by jackburton

Could you try with hrev35970 or later ? It shouldn't crash anymore. Probably something still won't work, but at least we could see some error message, if you start the email preflet from the Terminal.

comment:5 Changed 9 years ago by jackburton

BTW, I cannot reproduce it here (on VirtualBox)

comment:6 Changed 9 years ago by vooshy

hrev35981 Tried today, took me a while to recreate and wont crashout to gdb anymore. just freezes, on first attempt at adding account goes to host server screen fine, but if you click back then ok to add again, it freezes.

Changed 9 years ago by vooshy

Attachment: 280310-shot added

hrev35981 - crash no gdb

comment:7 Changed 9 years ago by jackburton

Please launch the email preflet from the Terminal and paste here the output, so we can see where it hangs.

comment:8 Changed 9 years ago by vooshy

Okay, re-run from Terminal, will attach the output.

Changed 9 years ago by vooshy

Attachment: terminal-output-email added

terminal output

Changed 9 years ago by vooshy

Attachment: gdb-debug2308-email-28th added

gdb debug

comment:9 Changed 9 years ago by jackburton

I tried with your nameserver, too, but I cannot reproduce. Can you also attach your resolv.conf here ?

Changed 9 years ago by vooshy

Attachment: resolv.conf added

resolv file

comment:10 Changed 9 years ago by jackburton

Thanks! Actually, I can reproduce this everytime, also with my configuration. I wasn't able because I was launching E-mail with

LD_PRELOAD=libroot_debug.so E-mail

trying to find out what's wrong. Which is weird, though, since it should crash that way too.

comment:11 Changed 9 years ago by pulkomandy

Resolution: fixed
Status: newclosed

According to vooshy on IRC, this is not hapenning anymore, so closing it.

Note: See TracTickets for help on using tickets.