Opened 9 years ago

Closed 2 months ago

#5658 closed bug (fixed)

Microsoft Wireless Multimedia Keyboard doesn't work on kernel debugging land

Reported by: fano Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/Keyboard/USB Version: R1/Development
Keywords: Cc: mdisreali@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Pressing Alt-SysReq (R Sist on the Micro$oft keyboard) - D you obtain correctly the kernel debugging land prompt (and it recognized correctly that the keyboard is USB) but then when you try to write nothing happens... you've to found a legacy PS/2 keyboard to do your operation and press "co" to return to the OS. After OS is "restarted" the wireless keyboard is working again correctly.

Maybe using a wired USB keyboard is used it works, but I not have one, I've only a legacy wired PS/2 keyboard!

Attachments (2)

listusb_am5620.txt (12.9 KB) - added by Disreali 9 years ago.
listdev_am5620.txt (3.5 KB) - added by Disreali 9 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 9 years ago by fano

Component: - GeneralDrivers/Keyboard/USB
Owner: changed from nobody to mmlr

comment:2 Changed 9 years ago by Disreali

Cc: mdisreali@… added

comment:3 Changed 9 years ago by Disreali

I have the a similar issue with my wired usb keyboard. However, my system does not have any ps/2 ports, just 10 or more usb ports, so when it enters KDL or some gdb screens all I can do is do a hard-reset.

Changed 9 years ago by Disreali

Attachment: listusb_am5620.txt added

Changed 9 years ago by Disreali

Attachment: listdev_am5620.txt added

comment:4 Changed 9 years ago by mmlr

That's not actually a bug. Normal OS operation and KDL are two totally different things, the KDL is a highly limited environment. Only limited USB keyboard support has been implemented. For example it requires being hooked to a UHCI root port right now, so not a hub and not an OHCI controller.

comment:5 in reply to:  4 ; Changed 9 years ago by Disreali

Replying to mmlr:

Only limited USB keyboard support has been implemented.

Are you saying that my issue should be filed on a separate ticket?

comment:6 in reply to:  5 Changed 9 years ago by mmlr

Replying to Disreali:

Replying to mmlr:

Only limited USB keyboard support has been implemented.

Are you saying that my issue should be filed on a separate ticket?

No, I just added the comment to explain what's going on. The issue is most likely the same.

comment:7 Changed 9 years ago by Disreali

I don't know about the reporter, but now my usb keyboard works in gdb and kdl prompts on hrev36336. Thanks.

comment:8 Changed 9 years ago by Disreali

Correction:

If the system goes int gdb the usb keyboard works and I can use ALT+SysRq+D to bring up KDL where keyboard also works.

I system goes into KDL directly, the keyboard does not work and only recourse is a hard reset.

comment:9 Changed 9 years ago by anevilyak

That's a known issue that applies to all USB keyboard, for them to work in KDL you have to enter and leave KDL manually at least once first.

comment:10 Changed 9 years ago by fano

Has a Patch: unset

I'm trying ALHA2 now pressing ALT+SySREQ+D does nothing anymore using my USB WIreless keyboard... well maybe is best: as you MUST reboot to exit in that case.

So, sorry, it is not solved for me!

comment:11 Changed 7 years ago by Disreali

You may want to test again. There have been many changes in the past 19 months. On my system, I no longer need to enter and then leave KDL manually for my keyboard to work in actual KDL crashes.

comment:12 Changed 2 months ago by waddlesplash

Resolution: fixed
Status: newclosed

Probably fixed, no reply in 7 years.

Note: See TracTickets for help on using tickets.