Opened 10 years ago

Closed 9 years ago

#5670 closed bug (fixed)

BezillaBrowser triggers app-server crash

Reported by: Disreali Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc: mdisreali@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Bezilla will randomly cause app-server to crash. In this particular instance, there were 4 tabs open, I clicked on a link to go to the next page a forum which I was reading, and the crash occurred.

hrev35981 installed on hw, Bezilla installed via the installoptionalpackage command

Keyboard input does not work after the crash, possible because it is usb.

photo of crash attached.

Attachments (4)

PHTO0294.JPG (352.6 KB ) - added by Disreali 10 years ago.
listdev_am5620.txt (3.5 KB ) - added by Disreali 10 years ago.
listusb_am5620.txt (12.9 KB ) - added by Disreali 10 years ago.
crash.JPG (52.5 KB ) - added by Disreali 10 years ago.

Download all attachments as: .zip

Change History (14)

by Disreali, 10 years ago

Attachment: PHTO0294.JPG added

by Disreali, 10 years ago

Attachment: listdev_am5620.txt added

by Disreali, 10 years ago

Attachment: listusb_am5620.txt added

comment:1 by Disreali, 10 years ago

Attaching listdev and listusb output.

comment:2 by axeld, 10 years ago

Component: - GeneralServers/app_server
Owner: changed from nobody to axeld

When you get into GDB (or the kernel debugger, for that matter), always issue the "bt" command to retrieve a back trace - without this, bug reports like this are pretty much meaningless. I hope you can reproduce this one!

(also, the first message that is not visible on the screenshot is also important)

comment:3 by axeld, 10 years ago

Sorry, I did not read the keyboard comment before. Since BeZilla works flawlessly for me, there is probably not much we can do about this before retrieving more info. You don't have a PS/2 keyboard handy, haven't you?

comment:4 by stippi, 10 years ago

Recently I have done modifications to the libbe<->app_server communication, and it is possible to upgrade Haiku in a way that the non-system libbe.so is not updated in hybrid builds. Please tell how you upgraded Haiku to the revision that you are currently running and what GCC version Haiku and BeZillaBrowser are respectively using.

in reply to:  4 comment:5 by Disreali, 10 years ago

Replying to axeld:

You don't have a PS/2 keyboard handy, haven't you?

Unfortunately, this system does not have any ps/2 connectors, just lots of usb.

Replying to stippi:

Recently I have done modifications to the libbe<->app_server communication, and it is possible to upgrade Haiku in a way that the non-system libbe.so is not updated in hybrid builds. Please tell how you upgraded Haiku to the revision that you are currently running and what GCC version Haiku and BeZillaBrowser are respectively using.

I downloaded the hrev35981 gcc2/hybrid anyboot image, dd'ed to a usb stick and booted off the stick. I was happily surprised that Haiku worked and proceeded to install from the usb stick onto a 10GB partition created with gparted run from a linux livecd. Currently, Haiku is set to gcc2. BeZilla was installed via the 'installoptionalpackage' script, though I have no idea which gcc version created it. I had considered going back to using a vm in order to capture crash data more easily, but I don't know if the same errors will occur on a vm.

comment:6 by Disreali, 10 years ago

Attaching photo of the most recent crash.

by Disreali, 10 years ago

Attachment: crash.JPG added

comment:7 by axeld, 9 years ago

Does this still happen with hrev36523?

BTW your USB keyboard should now work in this situation.

comment:8 by Disreali, 9 years ago

Cc: mdisreali@… added

I have no seen the issue in hrev36511-alpha-rc, though I've only had it running for one day. And yes, the usb keyboard works in gdb, and has for several revs.

comment:9 by Disreali, 9 years ago

I've have not experienced this issue for some time. Now using hrev36542-alpha-rc. I think this ticket can be closed.

comment:10 by bonefish, 9 years ago

Resolution: fixed
Status: newclosed

Thanks for the update! Closing.

Note: See TracTickets for help on using tickets.