Opened 10 years ago

Closed 8 years ago

#5679 closed bug (fixed)

Discriminate between process and thread signals

Reported by: bonefish Owned by: bonefish
Priority: normal Milestone: R1
Component: System/POSIX Version: R1/Development
Keywords: Cc: planche2k@…
Blocked By: Blocking: #7235
Has a Patch: no Platform: All

Description

Currently Haiku (hrev36030) handles a signal sent to a process (e.g. by kill()) as a signal to the team's main thread. That's incorrect. The signal should be handled by any of the team's threads that doesn't block this signal. Cf. http://www.opengroup.org/onlinepubs/9699919799/functions/V2_chap02.html#tag_15_04.

Change History (4)

comment:1 by andreasf, 10 years ago

Cc: planche2k@… added

comment:2 by bonefish, 9 years ago

Blocking: 7235 added

(In #7235) Looks like a duplicate of #5679.

comment:3 by bonefish, 8 years ago

Owner: changed from nobody to bonefish
Status: newin-progress

comment:4 by bonefish, 8 years ago

Resolution: fixed
Status: in-progressclosed

Fixed in hrev42116.

Note: See TracTickets for help on using tickets.