Opened 9 years ago

Closed 8 years ago

#5686 closed enhancement (fixed)

Implement pthread cancellation

Reported by: bonefish Owned by: bonefish
Priority: normal Milestone: R1
Component: System/POSIX Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #4029
Has a Patch: no Platform: All

Description

Implement pthread_cancel(). Could probably be implemented via a signal, although then the overhead for implementing cancellation points might be greater than desired (additional syscalls). Alternatively explicit kernel support would be possible.

Open Group Base Specs: Thread Cancellation

Change History (5)

comment:1 Changed 9 years ago by scottmc

Resolution: duplicate
Status: newclosed

Duplicate of #4029

comment:2 Changed 9 years ago by bonefish

Resolution: duplicate
Status: closedreopened

comment:3 Changed 9 years ago by bonefish

Blocking: 4029 added

(In #4029) Switching open/dup with #5686 as it has more useful info.

comment:4 Changed 8 years ago by bonefish

Owner: changed from nobody to bonefish
Status: reopenedin-progress

comment:5 Changed 8 years ago by bonefish

Resolution: fixed
Status: in-progressclosed

Implemented in hrev42116.

Note: See TracTickets for help on using tickets.