Opened 9 years ago

Closed 9 years ago

#5689 closed bug (fixed)

Page fault on booting (Acer Aspire One)

Reported by: myob Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: VM Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Using hrev36031 gcc2/hybrid (haiku-files build), I get a recreatable page fault on attempting to boot off CD on my Acer Aspire One. This is currently running the Alpha so formerly worked.

The final lines printed to the on-screen debug output before the fault are:

Can't open/create /var/swap: No such file or directory vm_page_fault: kernel thread accessing invalid user memory! vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0xc0c0, ip 0x82542f04, write 0, user 0, thread 0xd

The kdl starts with: PANIC: vm_page_fault: unhandled page fault in kernel space at 0xc0c0, ip 0x8254f04

There is no serial port on the netbook so I can't easily get anything more off it.

Change History (6)

comment:1 by myob, 9 years ago

Can't open/create /var/swap: No such file or directory
vm_page_fault: kernel thread accessing invalid user memory!
vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0xc0c0, ip 0x82542f04, write 0, user 0, thread 0xd

forgot you need to break lines...

comment:2 by bonefish, 9 years ago

If you have a FAT32 partition or USB stick, you can save the previous syslog from within the boot loader: Start Haiku normally (no on-screen debug output), when it panics, reboot, immediately enter the boot loader (the one from the CD) by holding down the Shift key, enter the Debug menu and save the syslog.

More info: http://dev.haiku-os.org/wiki/ReportingBugs#KernelBugs, particularly the Syslog section.

comment:3 by myob, 9 years ago

I'm running off CD, will it have saved the syslog to the BFS partition I have there or not?

in reply to:  3 comment:4 by bonefish, 9 years ago

Replying to myob:

I'm running off CD, will it have saved the syslog to the BFS partition I have there or not?

Only when the boot disk is writable (i.e. not a CD) the normal syslog file is written. When Haiku panics, the file will not contain the kernel debugger output, though. Nothing is written to the file before the syslog_daemon has been started. Even when it is running, the most recent output might not have been sent to it or written to the file yet. Even if it has been written to the file, due to caching, it might not actually have been written to disk and might be lost after reboot. So, usally for a panic during the boot process the syslog file is not helpful, even if you wouldn't boot off CD.

The syslog you can display or save from within the boot loader should be complete however. If you don't have a FAT32 partition or USB stick at hand, you can at least display it there and take pictures of the last part. The stack trace and the output up to a few lines before entering the kernel debugger would be of primary interest.

comment:5 by myob, 9 years ago

This laptop boots Alpha2 perfectly now. Clearly the ongoing VM work around the time of the issue was the cause, and then the fix.

comment:6 by stippi, 9 years ago

Resolution: fixed
Status: newclosed

Thanks for the update!

Note: See TracTickets for help on using tickets.