Opened 9 years ago

Closed 5 months ago

#5760 closed bug (duplicate)

GM965/GL960 Video Driver Graphics Corruption

Reported by: essial Owned by: nobody
Priority: normal Milestone: R1/beta2
Component: Drivers/Graphics/intel_extreme Version: R1/Development
Keywords: Cc:
Blocked By: #3484 Blocking:
Has a Patch: no Platform: x86

Description

Booting into Haiku using the latest SVN build as of April 19, 2010 produces a very odd screen issue. The resolution is detected properly, but the graphics is somewhat corrupt. You can see faint 'waves' going down the screen at an angle (refresh/sync issue?), pixels will flicker random colors in the haiku logo in the wallpaper, and the colors are generally wrong. Speed wise it runs great, it just looks bad. Images attached were taken with my android phone.

Video Card Name: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller PCI Vendor ID: 0x8086 PCI Device ID: 0x2A02 Rev: 0x0C

Attachments (2)

IMAG0058.jpg (89.8 KB) - added by essial 9 years ago.
zoomed.jpg (326.4 KB) - added by essial 9 years ago.

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by essial

Attachment: IMAG0058.jpg added

Changed 9 years ago by essial

Attachment: zoomed.jpg added

comment:1 Changed 9 years ago by essial

This is a 1280x800 laptop screen by the way.

comment:2 Changed 9 years ago by Disreali

This looks to be a duplicate of ticket:3484

comment:3 Changed 9 years ago by essial

It is not a resoultion problem. The resolution appears to be correct -- 1280x800, so this is not a dupe of that ticket.

Also, this is my Xorg modeline that works in linux: Modeline "1280x800"x0.0 71.26 1280 1296 1344 1424 800 801 804 834 -hsync -vsync (50.0 kHz)

If I knew how to get the modeline out on haiku I would submit that as well.

comment:4 Changed 2 years ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:5 Changed 10 months ago by pulkomandy

Milestone: R1/beta2

comment:6 Changed 5 months ago by waddlesplash

Blocked By: 3484 added
Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.