Opened 9 years ago

Closed 7 years ago

Last modified 14 months ago

#5815 closed bug (fixed)

KDL at boot

Reported by: cb88 Owned by: axeld
Priority: normal Milestone: R1/beta1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I checked all options in the boot menu (disable acpi etc...) and it still doesn't boot it was fine as of yesterday.

I get something about a spinlock and later something about no io-apic. Will post screenshots I a little while.

This is on a gateway NV53 (acer made) with an athlon II M300 (K10)

Attachments (3)

1.jpg (117.6 KB ) - added by cb88 9 years ago.
2.jpg (149.4 KB ) - added by cb88 9 years ago.
3.jpg (157.8 KB ) - added by cb88 9 years ago.

Download all attachments as: .zip

Change History (24)

by cb88, 9 years ago

Attachment: 1.jpg added

by cb88, 9 years ago

Attachment: 2.jpg added

by cb88, 9 years ago

Attachment: 3.jpg added

comment:1 by cb88, 9 years ago

Note that I can still boot from the partition with

qemu-kvm /dev/sda then select haiku in grub and it boots up fine so its hardware specific

comment:2 by cb88, 9 years ago

If I disable ACPI only I can boot. If apm is also disabled I cannot boot I think that is expected? If I need to provide anything else I would be more than happy to.

comment:3 by tqh, 9 years ago

Screenshot 3 shows that you've passed ACPI initialization as it publishes the namespace node. I don't think you should have APM enabled with ACPI. Not sure what the cause is though.

comment:4 by korli, 9 years ago

There seems to be a loop with add_memory_type_range() with an uncached mtrr type.

in reply to:  4 comment:5 by bonefish, 9 years ago

Milestone: R1R1/alpha2
Version: R1/alpha1R1/Development

cb88, please always give the exact revision you're testing with. "today" and "yesterday" are really kind of relative.

It would be nice to get a full syslog (with the on-screen debug output disabled). Cf. http://dev.haiku-os.org/wiki/ReportingBugs#KernelBugs].

Replying to korli:

There seems to be a loop with add_memory_type_range() with an uncached mtrr type.

Seems ACPI is mapping the same page several times. Should be harmless, though.

comment:6 by tqh, 9 years ago

You should try a build after hrev36531 since it or hrev36511 might fix this.

bonefish, korli, yes I think ACPI maps one page at a time unless you set a define, due to some ACPI implementations.

comment:7 by cb88, 9 years ago

As of hrev36568 it still will not boot with acpi... also not that with console logging it ALWAYS crashes or locks up whereas with logging turned off and acpi turned off I can boot to the desktop. Also with console logging off the disk icon at boot is a bit slow to light up... it takes much longer than qemu.

I tried lots of different options all of them ending in KDL... except no logging and acpi off. I can attach onscreen syslog but I would rather someone suggest boot options they want to see before I do that. Would the syslog of the system booted without acpi be of interest?

Also whether or not the logging is paging or continuous (pressing spacebar vs letting it scroll on its own) makes a difference in where it ends which leaves me confused as to what I should report/attach.

My HD is in AHCI mode if that makes any difference and is really the only option I can set in my "BIOS/firmware" other than video ram amount.

comment:8 by tqh, 9 years ago

AHCI should be fine. APM should be off. The rest we should try to track down. Is the panic the same as in screenshot 1 still?

Stupid question, but you are building or using images from trunk and not alpha2 images? I just want to be sure you have the latest code so we look in the right places.

comment:9 by bonefish, 9 years ago

Replying to cb88:

As of hrev36568 it still will not boot with acpi... also not that with console logging it ALWAYS crashes or locks up whereas with logging turned off and acpi turned off I can boot to the desktop.

Please don't use the on-screen debug output. It is mostly a legacy option that only in rare cases has any use at all. It definitely has the side effect of screwing up timing sensitive processes. The preferred way to get the same information (without the side effects) is the debug syslog feature, which is turned on by default. The only drawback I know of is that when the system cannot be reset (neither via KDL nor via hardware button) it is not possible to access the data, since the machine has to be turned off (well, I've seen a laptop being turned off and on again fast enough for the memory to still keep the data).

I tried lots of different options all of them ending in KDL... except no logging and acpi off. I can attach onscreen syslog but I would rather someone suggest boot options they want to see before I do that. Would the syslog of the system booted without acpi be of interest?

I don't think so, but feel free to attach it anyway.

Also whether or not the logging is paging or continuous (pressing spacebar vs letting it scroll on its own) makes a difference in where it ends which leaves me confused as to what I should report/attach.

Please don't use the on-screen debug output at all. If you have FAT32 partition or USB stick the debug syslog feature in the boot loader menu is the easiest way to get the syslog. Please have a look at the link I posted earlier (there's a Syslog subsection).

comment:10 by cb88, 9 years ago

Ok, I attempted to boot from USB thereby avoiding GRUB and any clobbering it might do... but the problem is that I cannot get the syslog since it is not in the bootloader after a cold boot (even if only off for a few seconds)

I can't do a warm reboot from KDL because I can't get into KDL I can get into KDL with ACPI off though so I know that works and is a problem between the keyboard and chair.

mmadia suggested I ask Ingo about it.. I'd be willing to write data to my flash drive and remove my HD if needed. The boot does not get as far as mounting the BFS partition I think since the disk Icon doesn't come on. On hrev36961 build directly to /dev/sdb (flash drive) ... also without ACPI Haiku can't find the partition probably because there isn't one as I just switched from building the to my HD partition to my flash drive should I do something different from that now? It has been awhile since I build a haiku USB image.

comment:11 by stippi, 9 years ago

Haiku does not need a partition, the bootable volume can also be the entire device itself. When you build from source, every step to make that volume bootable has already been taken care of, the only problem can be the BIOS, for example when it looks for an MBR when there is none.

in reply to:  11 comment:12 by cb88, 9 years ago

stippi ... the USB boots fine but Haiku can't find the partition later in the boot process I thought it was clear that I can get as far as the bootloader and booting haiku its after that where I have the issues.

--Haiku locks up at the drive icon (default options)

*Syslog is not available at reboot *Warm reboot not possible -- atl+sysreq+d doesn't work (works if not locked up)

--onscreen output causes KDLs whereas default just locks up --When booting from USB with the image wrote to the whole device Haiku can't find the partition and therefore KDLs.

*This is with ACPI disabled which should boot but doesn't *Note that it seems Haiku crashes before the disks are mounted since I mounted my partition with bfs_shell and there was no syslog

comment:13 by scottmc, 8 years ago

any progress on this one? Can you retest with a recent nightly and report back here? Include screenshots/photos if possible.

comment:14 by scottmc, 8 years ago

Milestone: R1/alpha3R1/beta1

pushing out to R1/beta1 while we wait for an update on retesting this one.

comment:15 by scottmc, 8 years ago

Blocking: 7665 added

comment:16 by cb88, 8 years ago

I am currently hitting the errors on ticket #8085 with the bios handoff it hangs while handing of my usb controller iirc.

Last edited 8 years ago by diver (previous) (diff)

comment:17 by diver, 7 years ago

Component: SystemSystem/Kernel
Owner: changed from nobody to axeld

comment:18 by x-ist, 7 years ago

@cb88: According to your statement in http://www.haiku-os.org/community/forum/haiku_boots_my_gateway_nv53_athlon_m300_system_again this ticket can be closed.
Please confirm.

comment:19 by cb88, 7 years ago

Yes it works so should be ok to close this one.

No hangs on boot and it boots up fairly quick.

comment:20 by scottmc, 7 years ago

Resolution: fixed
Status: newclosed

comment:21 by waddlesplash, 14 months ago

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.