Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5825 closed bug (fixed)

Enabling of ACPI and usage of ACPI programs (cpu freq, battery info) causes mouse to lose sync

Reported by: kallisti5 Owned by: tqh
Priority: normal Milestone: R1
Component: Drivers/ACPI Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

New Laptop (HP nc6230, Intel 82801 chipset) hrev36447 (gcc2/hybrid)

Example:

  • boot Haiku
  • enable ACPI
  • reboot
  • launch CPU freq, slide stuff around
  • launch battery info, click on batteries and stuff
  • mouse begins to get sluggish.
    • mouse movements get to be ~3 seconds off (move mouse left and up... three seconds later mouse moves left and up. (via trackpad)
  • quit battery monitor
  • quit cpu speed slider
  • mouse will return to normal after ~ 5 minutes.

syslog coming in a few minutes.

Attachments (1)

syslog (239.3 KB) - added by kallisti5 9 years ago.

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by kallisti5

Attachment: syslog added

comment:1 Changed 9 years ago by kallisti5

Component: Drivers/Mouse/USBDrivers/ACPI
Owner: changed from mmlr to nobody

comment:2 Changed 9 years ago by kallisti5

Platform: Allx86
Version: R1/alpha1R1/Development

comment:3 Changed 9 years ago by mmadia

Owner: changed from nobody to tqh
Status: newassigned

tqh, is this ok to assign to you?

comment:4 Changed 9 years ago by tqh

I think so. This looks like a problem with the ACPI Embedded Controller.

comment:5 Changed 9 years ago by tqh

Resolution: fixed
Status: assignedclosed

This should be fixed in hrev36511. Please test again and reopen if there are still problems. Thanks for testing.

comment:6 Changed 9 years ago by kallisti5

In the interests of R1A2 I verified hrev36511 has resolved the ACPI issue in my instance as well.

Note: See TracTickets for help on using tickets.