Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#5839 closed bug (fixed)

MIME types not recognised on NTFS - cant play music / video from NTFS partition

Reported by: streak Owned by: mmu_man
Priority: normal Milestone: R1/alpha3
Component: File Systems/NTFS Version:
Keywords: Cc: kvdmanya@…, xray7224@…, khallebal@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

since few rev's [ and on hrev36511 ] i cant play any media files (mp3 / avi / other) from NTFS. Even dragging / dropping files onto media player not starting it..

The same copied media files on BFS works [media player starts playing it ].

Change History (22)

comment:1 by korli, 9 years ago

This could have started with hrev36178 and hrev36296 from François. Though this problematic fs support should also detected by the registrar and not rely on attributes on this case.

comment:2 by streak, 9 years ago

Seems every file from NTFS [mounted as read/write] cannot be opened/started. Mime detection fails with media files aswell as with simple like -> *.txt

comment:3 by streak, 9 years ago

Tested on official A2

comment:4 by kvdman, 9 years ago

Cc: kvdmanya@… added

I can confirm this problem.

comment:5 by streak, 9 years ago

Still occurs in hrev37017 [ r1a2 nightly ]

comment:6 by xray7224, 9 years ago

Cc: xray7224@… added

comment:7 by streak, 9 years ago

Summary: Clicking on media files (mp3/avi) on NTFS dont start mediaplayerMIME types not recognised on NTFS - cant play music / video from NTFS partition

comment:8 by streak, 9 years ago

still present in hrev37693

comment:9 by khallebal, 9 years ago

Cc: khallebal@… added

comment:10 by khallebal, 9 years ago

hi shouldn't this ticket get a higher priority?,just a suggestion as this bug is quite ennoying and renders the support for the ntfs useless.

comment:11 by diver, 9 years ago

Also there have been several releases of ntfs-3g http://www.tuxera.com/community/release-history

comment:12 by diver, 9 years ago

BTW, one could try to get an image of Haiku prior hrev36178 and get ntfs driver from there until this bug is fixed.

comment:13 by stippi, 9 years ago

If incomplete attribute support in the NTFS fs add-on is the problem, then it sounds like the actual problem may be in Tracker. Maybe it invokes the manual MIME-type detection not in all situations when it should. Ups, just saw korli already mentioned this in the first comment.

comment:14 by stippi, 9 years ago

Better yet: Tracker should simply sniff any MIME-type of a file that it displays. On BFS volumes, you get unrecognized files - until you drag them, or even until you select them and open a menu. Pretty useless IMHO, it might as well figure out the type right away. And when there is an error setting the type attribute (which I presume will be the case on NTFS), then it should fall-back to fake the type like on a non attribute capable FS.

in reply to:  14 comment:15 by tangobravo, 9 years ago

Replying to stippi:

Better yet: Tracker should simply sniff any MIME-type of a file that it displays.

Agreed. I suppose there were performance reasons to think about back in the 90s, but this behaviour is one of the very few areas where Haiku feels dated to me (compared to the rest of the OS, which is "live", fast, and responsive).

comment:16 by khallebal, 9 years ago

i totally agree with tangobravo i don't think the prob is in the ntfs driver,but in the tracker,as i remember having this same prob back in the beos days.

comment:17 by anevilyak, 9 years ago

It's not quite that simple, the problem is Tracker just relies on the mime sniffer updating the BEOS:MIME attribute on the file, it doesn't sniff it out as it goes. Since other filesystems (i.e. NTFS) won't have that attribute, it won't be able to read the type from it that way. iirc on R5 the built-in NTFS driver was hardcoded to present a fake mime attribute for specific file extensions (i.e. .mp3) for Tracker to work with.

comment:18 by streak, 9 years ago

Can some portions of the source be reverted to previous release, then? [MIME detecting on NTFS was working in R1A1, for example ]

comment:19 by stippi, 9 years ago

Owner: changed from 3dEyes to mmu_man
Status: newassigned

in reply to:  18 comment:20 by mmu_man, 9 years ago

Replying to streak:

Can some portions of the source be reverted to previous release, then? [MIME detecting on NTFS was working in R1A1, for example ]

No it was not working. It was hardcoded by an internal (and incomplete) extension to mime table.

At least this should be moved to a mime fs overlay, instead of being duplicated in each fs.

Though attributes should be correctly saved to NTFS named streams so there must be some problems.

comment:21 by korli, 9 years ago

Resolution: fixed
Status: assignedclosed

Fixed in hrev38324.

comment:22 by mmu_man, 9 years ago

Oh thanks for that one :-)

Note: See TracTickets for help on using tickets.