Opened 13 years ago

Closed 13 years ago

#586 closed bug (invalid)

count_font_families() crash

Reported by: marcusoverhagen Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc: diver
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by axeld)

During startup, the initial Terminal crashed while it opened.

This wasnt reproduceable so far. Revision 17447

GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

Thread 45 caused an exception: Segment violation
Reading symbols from /boot/beos/system/lib/libbe.so...(no debugging symbols
found)...done.
Loaded symbols for /boot/beos/system/lib/libbe.so
Reading symbols from /boot/beos/system/lib/libtracker.so...(no debugging symbols
found)...done.
Loaded symbols for /boot/beos/system/lib/libtracker.so
Reading symbols from /boot/beos/system/lib/libtextencoding.so...
(no debugging symbols found)...done.
Loaded symbols for /boot/beos/system/lib/libtextencoding.so
Reading symbols from /boot/beos/system/lib/libroot.so...done.
Loaded symbols for /boot/beos/system/lib/libroot.so
Reading symbols from /boot/beos/system/lib/libgame.so...done.
Loaded symbols for /boot/beos/system/lib/libgame.so
Reading symbols from /boot/beos/system/lib/libstdc++.r4.so...done.
Loaded symbols for /boot/beos/system/lib/libstdc++.r4.so
Reading symbols from /boot/beos/system/lib/libtranslation.so...done.
Loaded symbols for /boot/beos/system/lib/libtranslation.so
Reading symbols from /boot/beos/system/lib/libmedia.so...done.
Loaded symbols for /boot/beos/system/lib/libmedia.so

[Switching to team /boot/beos/apps/Terminal (45) thread Terminal (45)]
0x0074e3c9 in memcpy () from /boot/beos/system/lib/libroot.so
(gdb) bt
#0  0x0074e3c9 in memcpy () from /boot/beos/system/lib/libroot.so
#1  0x00709f28 in realloc () from /boot/beos/system/lib/libroot.so
#2  0x0039dafc in BList::Resize () from /boot/beos/system/lib/libbe.so
#3  0x0039d51d in BList::AddItem () from /boot/beos/system/lib/libbe.so
#4  0x00350843 in BObjectList<style>::AddItem ()
   from /boot/beos/system/lib/libbe.so
#5  0x002f04f2 in BPrivate::FontList::_Update ()
   from /boot/beos/system/lib/libbe.so
#6  0x002f0587 in BPrivate::FontList::_Update ()
   from /boot/beos/system/lib/libbe.so
#7  0x002f06c9 in BPrivate::FontList::_UpdateIfNecessary ()
   from /boot/beos/system/lib/libbe.so
#8  0x002f0bc5 in BPrivate::FontList::CountFamilies ()
   from /boot/beos/system/lib/libbe.so
#9  0x002f11de in count_font_families () from /boot/beos/system/lib/libbe.so
#10 0x00211d42 in PrefHandler::_ConfirmFont ()
#11 0x00211549 in PrefHandler::PrefHandler ()
#12 0x00212f63 in TermApp::TermApp ()
#13 0x00210086 in main ()
(gdb)

Change History (2)

comment:1 Changed 13 years ago by diver

Cc: diver added

comment:2 Changed 13 years ago by axeld

Description: modified (diff)
Platform: All
Resolution: invalid
Status: newclosed

Since it didn't happen again, and the code doesn't look faulty at all, I move this to the attic - it was probably caused by some other bug, and not related to count_font_families() at all.

Note: See TracTickets for help on using tickets.