Opened 9 years ago

Closed 4 months ago

Last modified 4 months ago

#5880 closed bug (fixed)

Reboot and Shutdown not working correctly (don't reopen, create new ticket)

Reported by: jahaiku Owned by: tqh
Priority: normal Milestone: R1
Component: Drivers/ACPI Version: R1/alpha1
Keywords: hang shutdown reboot Cc: umccullough, secris1@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is gcc4 build of hrev36566 on Acer Aspire One 150 (Intel Atom n270).

Now since ACPI is enabled I see the following behaviour on my NetBook:
Reboot: System is shutting down, but when the reboot should be done the screen gets blank and nothing more happens (not reboot)
Shutdown: System is shutting down and the little status dialog is showing things which happens, but at the end the dialog is gone, but the system is NOT powered off. (BackgroundImage is shown - I got no dialog, that shutdown failed)

Attachments (1)

syslog Keldrim (552.0 KB) - added by Keldrim 15 months ago.
01.02.2018

Download all attachments as: .zip

Change History (27)

comment:1 Changed 9 years ago by tqh

Can you try going in to kernel debugger (ctrl + alt + sys req + d) and see what the end lines of the command 'syslog' returns?

Also what 'threads' and 'sc <threadnr>' shows for any interesting threads can also help.

Typing 'co' should continue, leaving the debugger.

comment:2 in reply to:  1 ; Changed 9 years ago by jahaiku

Replying to tqh:

Can you try going in to kernel debugger (ctrl + alt + sys req + d) and see what the end lines of the command 'syslog' returns?

What is "sys req" Key?

comment:3 in reply to:  2 Changed 9 years ago by humdinger

Replying to jahaiku:

What is "sys req" Key?

Normally, it's the PrintScreen key.

comment:4 Changed 9 years ago by jahaiku

Sorry for the late answer:

I have tried to go to the kernel debugger, but this is NOT possible.
So I think that the kernel is not running anymore.

comment:5 Changed 9 years ago by del.bianco

I have the exact same problem as described in this ticket.

ctrl+alt+sysreq+d doesn't open the kernel debugger. It seems to me the system is very far at shutting down and therefore cannot show the debugger anymore. Even the LCD backlights are turned off when I try to reboot.

Are there any logs I could post? The system is an Acer One A110 running the Alpha2 anyboot image.

comment:6 Changed 9 years ago by jahaiku

I have retryed with hrev36888, which includes the new ACPI, but the reboot isn't working after this update, too.

comment:7 Changed 9 years ago by intermittentTransmission

Keywords: hang shutdown reboot added

I'm also getting a hang on shutdown/reboot. It says "shutting down..." but never leaves that screen.

Core i7 930 with GIGABYTE GA-X58A-UD3R motherboard, running Alpha 2.

comment:8 in reply to:  7 Changed 9 years ago by khallebal

Replying to intermittentTransmission:

I'm also getting a hang on shutdown/reboot. It says "shutting down..." but never leaves that screen.

Core i7 930 with GIGABYTE GA-X58A-UD3R motherboard, running Alpha 2.

my acer 5620 shuts down properly with the rv:37048 but do not restart,it goes down all the way,says "restarting" and stays that way. it could be that the ("SIGNAL UP") feature of the acer laptops that prevents them from shutting down or restarting,as this feature constantly keeps searching for wifi connections?

comment:9 Changed 9 years ago by khallebal

when my acer extensa 5620 is connected to a wifi it reboots properly,but when i'm in area where there is no wifi the system won't reboot.

so it looks like my message above has been confirmed by this behavior a couple of days ago.

comment:10 Changed 9 years ago by tqh

Ah, that is interesting info.

comment:11 in reply to:  10 Changed 9 years ago by jahaiku

Replying to tqh:

Ah, that is interesting info.

You have changed s.th. in hrev38585. I have tested this and it changed nothing in behavior.

comment:12 Changed 8 years ago by scottmc

Can you recheck this with a recent Haiku build?

comment:13 Changed 8 years ago by scottmc

Blocking: 7665 added

comment:14 in reply to:  12 Changed 8 years ago by jahaiku

Replying to scottmc:

Can you recheck this with a recent Haiku build?

I have rechecked with gcc4 build of hrev42125 with no change. I get exactly the same. For this I have updated to the latest bios.

comment:15 Changed 7 years ago by tqh

Resolution: fixed
Status: newclosed

Closing this as fixed, reopen if it is not.

comment:16 Changed 5 years ago by AlienSoldier

Not fixed for my Acer Aspire One. The screen stay blue (the background haiku blue). I remember that on rare occasion is got black and also stuck there forever.

comment:17 Changed 5 years ago by umccullough

Cc: umccullough added
Resolution: fixed
Status: closedreopened

I also have an Acer Aspire One AOA150, and this is not resolved for me. Another user in IRC reported his AOA150 is also still showing this problem.

Reopening the issue again.

comment:18 Changed 5 years ago by Secris

I have this issue one the AOA150 also

comment:19 Changed 5 years ago by Secris

Cc: secris1@… added

comment:20 Changed 5 years ago by del.bianco

Yep, same problem is still occurring on my AOA110 with a nightly build from last week. I hope to find some time to dive in to the problem, but I doubt I can contribute anything useful since ACPI/Bios etc are very low level.

Any pointers? :)

comment:21 Changed 5 years ago by Zap123

Still happening with the latest nightly, I have an AOA110 too.

comment:22 Changed 4 years ago by pulkomandy

Blocking: 7665 removed

shutdown issue != boot issue.

comment:23 Changed 15 months ago by Keldrim

Well a similar problem on my machine, with currently build hrev51776. Reboot works fine but on shutdown the system freezes and gets stuck (desktop still visible with the shutdown dialog window)and i have to power it off over the PSU switch.

Weird thing sometimes the shutdown works.

Attached a syslog.

Changed 15 months ago by Keldrim

Attachment: syslog Keldrim added

01.02.2018

comment:24 Changed 7 months ago by tqh

Please retest with hrev52303 or later.

comment:25 Changed 4 months ago by tqh

Resolution: fixed
Status: reopenedclosed

Closing this as there was no response and this one just gets reopened. It has old outdated info. If you have issues with shutdown, don't reopen this ticket, create a new ticket with title 'Shutdown fails on XXX' where XXX is your hardware.

comment:26 Changed 4 months ago by tqh

Summary: Reboot and Shutdown not working correctlyReboot and Shutdown not working correctly (don't reopen, create new ticket)
Note: See TracTickets for help on using tickets.