Opened 10 years ago

Last modified 4 years ago

#5884 assigned bug

Installing bootman does not result in bootable disk

Reported by: andreasf Owned by: nobody
Priority: normal Milestone: R1
Component: Applications/BootManager Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

At hrev36580 neither Installer's invocation of bootman nor running it again from Terminal result in a bootable hard drive:

Insert Boot-Disk and press any key

Same result after installing R5's bootman.

Disk is Intel-partitioned (two primary partitions), and previously GRUB from Ubuntu ~Gutsy was installed and working.

Change History (8)

comment:1 by laplace, 10 years ago

Since it does not work using R5's bootman either, I suspect your BIOS expects a GUID partition table. However bootman supports a MBR partition table only. Can you confirm my guess?

in reply to:  1 comment:2 by andreasf, 10 years ago

It's a 1996 SystemSoft MobileBIOS. I doubt it expects a GPT; how could I confirm that?

comment:3 by laplace, 10 years ago

I have no idea how to confirm that, but 1996 does not sound like it expects a GPT.

Did R5's bootman or an older version of Haiku's bootman ever work?

Can you restore the backup of the MBR that was created when you run Haikus bootman? If that does not work, can you install GRUB again, and boot from it?

in reply to:  3 comment:4 by andreasf, 10 years ago

Never tried bootman on this machine before. GRUB had its config for chainloading on the ext3 partition that I just repartitioned, therefore bootman...

Selecting Partition > Initialize > Intel Partition Map... for the raw disk in DriveSetup does not help.

Boot CDs and their boot menu let me boot into the partitions though.

comment:5 by laplace, 10 years ago

I have no idea what goes wrong here. Maybe someone else has a clue.

comment:6 by axeld, 9 years ago

Could you please retry? The hard-coded BIOS ID 0x80 of the boot device has been removed in hrev40167.

comment:7 by humdinger, 8 years ago

Owner: changed from laplace to nobody
Status: newassigned

Is this still valid?

comment:8 by un_spacyar, 4 years ago

No answer in about 4 years. Maybe can be closed?

Note: See TracTickets for help on using tickets.