Opened 9 years ago

Closed 9 years ago

#5886 closed bug (duplicate)

keyboard not working on MacBook 2,0

Reported by: nitrofurano Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/alpha1
Keywords: macbook keyboard touchpad Cc: planche2k@…
Blocked By: #3927 Blocking:
Has a Patch: no Platform: All

Description

I'm trying Haiku R1/alpha1 (Revision 33109) on an Apple MacBook 2,0 The keyboard is not working at all, just like not recognized. As well, i have no external usb keyboards for testing if it works, but the usb mouse is working fine. The touchpad and the button below are also not working.

Change History (4)

comment:1 Changed 9 years ago by mmadia

Priority: highnormal

At this point, it's preferred to test R1/alpha 2 release candidate images from http://haiku-files.org . Though, i'm not sure if this bug still persists.

comment:2 Changed 9 years ago by andreasf

Cc: planche2k@… added

The bug persists on my MacBook1,1 at hrev36581.

It seems USB hubs don't work at all, neither Belkin KVM switch nor Apple Keyboard. Only mouse/keyboard connected to the frontmost USB port worked reliably. A mouse connected directly to the rear USB port had a lag of several seconds.

Adrien was speculating about an interrupt storm (cf. haiku-development) - but CPU is not at 100%. Syslog is being spammed by Atheros Wifi debug messages though...

comment:3 Changed 9 years ago by luroh

Resolution: duplicate
Status: newclosed

Closing as duplicate of #3927, which has a bit more information.

comment:4 Changed 9 years ago by luroh

Blocked By: 3927 added
Note: See TracTickets for help on using tickets.