Opened 13 years ago

Closed 11 years ago

#591 closed bug (fixed)

[Deskbar] doesn't redraw it's shelf

Reported by: diver Owned by: jackburton
Priority: normal Milestone: R1
Component: Applications/Deskbar Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by jackburton)

Deskbar doesn't redraw it's shelf if you open calendar: hold left or middle mouse button on deskbar's shelf for a second so calendar will appear and then click and hold shelf again. You should see deskbar window not to draw its content for a half of second.

Change History (10)

comment:1 Changed 13 years ago by axeld

Owner: changed from axeld to jackburton

comment:2 Changed 13 years ago by axeld

Under BeOS, the menu doesn't open again, and that's probably how they get around this.

comment:3 Changed 12 years ago by jackburton

Description: modified (diff)
Platform: All

This specific problem is gone after Waldemar's changes in rev 19349 and 19350. The calendar, though, doesn't close when you click on the deskbar the second time. But this is a different problem which, I think, should be fixed within the app_server ( see also comment 4 in bug #670 )

comment:4 Changed 12 years ago by diver

This bug is still here.

comment:5 Changed 11 years ago by nielx

Component: - Applications- Applications/Deskbar

Move to the proper component.

comment:6 Changed 11 years ago by kaoutsis

i can't reproduce here, hrev25184

comment:7 Changed 11 years ago by aldeck

I can still reproduce here, hrev27160, i'll have a look

comment:8 Changed 11 years ago by aldeck

Well i looked at the code, and there's a (~0.5sec) waiting loop in MouseDown to detect the long click. So i would say it is expected that the deskbar can't do anything during that time, or am i missing something?

I did a quick rewrite of the long click detection using a separate class/thread that sends "long click" messages to the view, it's cool and working but, before i cleanup and commit, i wonder if there wasn't a simpler solution or if i'm not working around a problem that should get fixed in the first place :-)

regards

comment:9 Changed 11 years ago by anevilyak

You could also just set up a half second BMessageRunner :) Busy waiting in MouseDown would definitely be an issue though.

comment:10 Changed 11 years ago by aldeck

Resolution: fixed
Status: newclosed

Fixed in hrev27258

Note: See TracTickets for help on using tickets.