Opened 9 years ago

Closed 8 years ago

#5950 closed bug (fixed)

shell's auto completion does not work with "dd" command!?

Reported by: khallebal Owned by: nobody
Priority: normal Milestone: R1
Component: Applications/Command Line Tools Version: R1/Development
Keywords: Cc: mdisreali@…, brecht@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

trying to "dd" a haiku-image to a usb stick noticed that the auto completion does not work anymore,that used to work on revisions prior rev:35xxxx,and that is reproducible on 3 different machines,so it's not a one system specific issue. should i attach a syslog or anything?

Change History (10)

comment:1 Changed 9 years ago by bonefish

Component: Applications/TerminalApplications/Command Line Tools
Owner: changed from jackburton to nobody
Version: R1/alpha1R1/Development

To be honest, I'd prefer to disable the auto-completion script completely. So far it has been a deep source of annoyance with virtually no benefit IMHO.

comment:2 Changed 9 years ago by axeld

Same here.

comment:3 Changed 9 years ago by Disreali

Cc: mdisreali@… added

I have never experienced it not working. On what rev did you find it to fail?

I find the auto-complete function extremely useful and use it often. I would hate to see it removed.

comment:4 in reply to:  3 Changed 9 years ago by bonefish

Replying to Disreali:

I have never experienced it not working. On what rev did you find it to fail?

I verified it with hrev36787. There haven't been any changes to the script for a while. E.g. type "dd if=/d" and hit tab: Doesn't work. Remove or rename /etc/bash_completion and retry in a fresh shell: Does work.

I find the auto-complete function extremely useful and use it often. I would hate to see it removed.

Don't confuse bash's built-in completion of command and path names with the bash_completion script. The latter tries to add command specific completions and in several cases just makes things work worse. I've never used the features it adds (e.g. completion of options), so I'm probably biased. Given that e.g. OpenSuse doesn't have it enabled by default either, I don't seem to be the only one unhappy with it.

comment:5 Changed 9 years ago by axeld

One of the first things I do after a clean Haiku installation is to delete the bash_completion folder. I haven't looked into disabling it, how to do that?

comment:6 in reply to:  5 Changed 9 years ago by bonefish

Replying to axeld:

One of the first things I do after a clean Haiku installation is to delete the bash_completion folder. I haven't looked into disabling it, how to do that?

OpenSuse doesn't have the /etc/bash_completion script, only the .d folder. I guess the script lives somewhere else and each user has to enable it somehow.

comment:7 Changed 9 years ago by bonefish

Resolution: fixed
Status: newclosed

Removed the bash_completion script in hrev37403.

comment:8 in reply to:  7 Changed 8 years ago by brecht

Resolution: fixed
Status: closedreopened

Replying to bonefish:

Removed the bash_completion script in hrev37403.

The bash_completion script included in the Haiku tree is a very old version (2006). It seems a lot of work has been done on it since then: http://bash-completion.alioth.debian.org/. Would you like to give an updated version a chance? Otherwise, I suggest completely removing it from the tree and making it available as an optional package. The subversion and git completion scripts can be included without the need for bash_completion. Shall we include and source these by default?

comment:9 Changed 8 years ago by brecht

Cc: brecht@… added

comment:10 Changed 8 years ago by brecht

Resolution: fixed
Status: reopenedclosed

hrev42257 updated bash_completion to a recent version and enabled it by default again. dd completion is fixed at least. Please report if you run into any other problems.

Note: See TracTickets for help on using tickets.