Opened 9 years ago

Closed 9 years ago

#5971 closed bug (fixed)

gcc2 buildtools fail to build

Reported by: tonestone57 Owned by: zooey
Priority: normal Milestone: R1
Component: Build System Version: R1/Development
Keywords: Cc: cpr420@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

hrev36795 gcc2 buildtools failed to build.

In file included from tconfig.h:5,
                 from /home/nickos/CODE/buildtools/legacy/gcc/gcc/libgcc2.c:33:
/home/nickos/CODE/buildtools/legacy/gcc/gcc/config/i386/xm-haiku.h:32: sys/wait.h: No such file or directory
/home/nickos/CODE/buildtools/legacy/gcc/gcc/libgcc2.c:41: stdlib.h: No such file or directory
/home/nickos/CODE/buildtools/legacy/gcc/gcc/libgcc2.c:42: unistd.h: No such file or directory
make[1]: *** [libgcc2.a] Error 1
make[1]: Leaving directory `/home/nickos/CODE/alpha2/generated-gcc2/cross-tools-build/gcc/gcc'
make: *** [cross] Error 2
ERROR: Building gcc failed.

Change History (13)

comment:1 Changed 9 years ago by mmadia

what OS is this from? They're building fine on FreeBSD 8.0

comment:2 Changed 9 years ago by tonestone57

Looks like something screwy with my OS (Debian) or files.

I reverted to older revision and same error. Seems like I will have to checkout a clean copy of buildtools to build.

Please close. Sorry for the noise.

comment:3 Changed 9 years ago by mmadia

Resolution: invalid
Status: newclosed

no problem.

comment:4 Changed 9 years ago by bga

Resolution: invalid
Status: closedreopened

Except that I am seeing exactly the same problem in Ubuntu Lucid (It started now, I was able to compile without problems some weeks ago in the same OS.

comment:5 Changed 9 years ago by augiedoggie

Cc: cpr420@… added

comment:6 Changed 9 years ago by axeld

I just built GCC2 on Ubuntu 10.04, and it worked flawlessly. Not that this will help you much, but it's not a general problem, at least.

comment:7 Changed 9 years ago by stippi

It may also be a problem that a build modifies files in the tree, IIRC. I did build GCC2 at least two times without reverting any possible changes on 10.04, but I do remember having to do that. What is definitely problematic is passing -jn to configure where n > 1. That just doesn't work for a GCC2 build reliably. Of course I have no recollection of the exact error I saw in both situations I mention above, so maybe it's still unrelated.

comment:8 Changed 9 years ago by mmadia

shakes fist at a bug in Build-O-Matic, which causes it to not send build failure reports for buildtools

Here's the output snippet from FreeBSD-8

In file included from st-dummy.c:1:
/Build-O-Matic/output/generated.x86gcc2/cross-tools/i586-pc-haiku/sys-include/posix/sys/types.h:9: config/types.h: No such file or directory
/Build-O-Matic/output/generated.x86gcc2/cross-tools/i586-pc-haiku/sys-include/posix/sys/types.h:11: BeBuild.h: No such file or directory
In file included from st-dummy.c:6:
/Build-O-Matic/output/generated.x86gcc2/cross-tools/i586-pc-haiku/sys-include/posix/signal.h:252: `#include' expects "FILENAME" or <FILENAME>
scan-types: could not invoke /Build-O-Matic/output/generated.x86gcc2/cross-tools-build/gcc/gcc/xgcc -B/Build-O-Matic/output/generated.x86gcc2/cross-tools-build/gcc/gcc/ -B/Build-O-Matic/output/generated.x86gcc2/cross-tools/i586-pc-haiku/bin/ -I/Build-O-Matic/output/generated.x86gcc2/cross-tools/i586-pc-haiku/include -DCROSS_COMPILE -DIN_GCC -O2 -U_FORTIFY_SOURCE -I./include -I. -I/Build-O-Matic/output/buildtools/legacy/gcc/gcc -Iinclude -I/Build-O-Matic/output/generated.x86gcc2/cross-tools/i586-pc-haiku/sys-include/posix -E -I/Build-O-Matic/output/buildtools/legacy/gcc/gcc/ on st-dummy.c
*** Error code 1

comment:9 Changed 9 years ago by zooey

Owner: changed from bonefish to zooey
Status: reopenedin-progress

The cause of the build problems should be fixed in hrev38383 (mismatch between expected and real legacy compiler version).

I'm still investigating as to why the mismatch has that effect, though - so I'm keeping this open.

comment:10 Changed 9 years ago by bga

So, I completelly erased my buildtools dir and redownloaded the sources. Now it works again. But it is really weird it is exactly that same problem that affected me and the original poster of this bug.

comment:11 Changed 9 years ago by bga

Oh, so it was probably just a coincidence then. As I redownloaded the code, I got the fix. thanks for looking into this.

comment:12 Changed 9 years ago by zooey

The problem with mismatching compiler versions is that haiku's configure script creates a folder which contains the compiler version as part of the path. Since this folder is being used by the generated cross compiler later, the haiku-specific (sys-include) headers will not be found (as the path expected by the compiler has been created under a different name).

comment:13 Changed 9 years ago by zooey

Resolution: fixed
Status: in-progressclosed
Note: See TracTickets for help on using tickets.