Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#5988 closed bug (fixed)

Print Server crashes.

Reported by: xeon3d Owned by: ithamar
Priority: normal Milestone: R1
Component: Printing Version: R1/alpha2
Keywords: jetdirect crash Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Hi.

Print Server crashes if it doesn't find an installed JetDirect Printer.

Story: I tried to install an HP printer which I expected that was connected to the network. Added it as a HP JetDirect and when it asked me what the IP address was and I went to check I found out that it actually wasn't connected at all to the network so I cancelled the dialog and the print server crashed.

After it, at each bootup or if I opened the printers preflet, it would ask me again for the IP or Name and after each cancel, the print server would crash.

Steps to reproduce:

  • Boot up Alpha 2
  • Open Printers Preflet
  • Add a JetDirect Printer
  • Cancel the following dialog
  • *PROFIT*

Change History (3)

comment:1 by ithamar, 10 years ago

Owner: changed from laplace to ithamar
Status: newin-progress

The problem is that the spool file will stay in the printer directory, and therefore everytime the print_server starts it'll try to print the file, i.e. it doesn't get properly cancelled on your 'Cancel'....

The crash however should not happen, I guess some error handling is either missing or wrong.

comment:2 by laplace, 10 years ago

Resolution: fixed
Status: in-progressclosed

Fixed in hrev36809.

Sorry Ithamar, didn't notice that you were working on it too.

comment:3 by ithamar, 10 years ago

no worries, was just looking at it, didn't quite "work" on it yet. Was planning it as a weekend activity :)

Nice work anyway!

Note: See TracTickets for help on using tickets.