Opened 10 years ago

Last modified 12 months ago

#5991 assigned bug

no boot path found, scan for all partitions...

Reported by: miq601 Owned by: nobody
Priority: normal Milestone: R1
Component: System/Boot Loader Version: R1/alpha2
Keywords: boot-failure Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

CD does not boot on Thinkpad 770. Displays "no boot path found, scan for all partitions...", then drops to bootloader menu. -> Select boot volume: "No boot volume found".

I've tried different CD-Rs none worked. Same CDs work on a Thinkpad T23.

Hardware: Pentium 233 MMX, Intel 430TX Chipset, 160MB SDRAM.

Change History (11)

comment:1 by luroh, 10 years ago

Is this the iso image or the anyboot image written to CD?

in reply to:  1 comment:2 by miq601, 10 years ago

Replying to luroh:

Is this the iso image or the anyboot image written to CD?

This is the iso image.

I've only tried the iso image so far, will test with anyboot now. It works on another machine, so i think CD and image are ok.

comment:3 by miq601, 10 years ago

Same problem with anyboot image.

comment:4 by mapecke, 9 years ago

I have encountered exactly the same problem when trying to install latest Haiku release on my IBM Thinkpad 600E (400 MHz Pentium II, 228 MB RAM, 20 GB HDD, CDROM, etc). It is the .iso image.

Tried with several BIOS settings, safe boot options, without any success : itt still reports "no boot path found, scan for all partitions..." and "no boot colume found".

Any ideeas I might try ? Thanks!

comment:5 by diver, 9 years ago

Try hrev38293 gcc2 anyboot image with IDE stack. IDE stack fails to compile on current (hrev39847) revision:

/home/haiku/trunk/src/add-ons/kernel/bus_managers/ide/scsi2ata.c: In function 'ata_exec_io':
/home/haiku/trunk/src/add-ons/kernel/bus_managers/ide/scsi2ata.c:469: error: 'SCSI_OP_VERIFY' undeclared (first use in this function)
/home/haiku/trunk/src/add-ons/kernel/bus_managers/ide/scsi2ata.c:469: error: (Each undeclared identifier is reported only once
/home/haiku/trunk/src/add-ons/kernel/bus_managers/ide/scsi2ata.c:469: error: for each function it appears in.)

...failed Cc /home/haiku/trunk/generated.x86gcc4/objects/haiku/x86/release/add-ons/kernel/bus_managers/ide/scsi2ata.o ...

comment:6 by anevilyak, 9 years ago

IDE vs ATA shouldn't make a difference in this context, this early in the boot process the stack hasn't been loaded at all yet since we're still in haiku_loader.

comment:7 by scottmc, 9 years ago

Blocking: 7665 added

comment:8 by axeld, 3 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:9 by waddlesplash, 17 months ago

Keywords: boot-failure added; boot removed

comment:10 by waddlesplash, 17 months ago

Blocking: 7665 removed

comment:11 by waddlesplash, 12 months ago

Still an issue?

Note: See TracTickets for help on using tickets.